Livebook: Failed to connect runtime - Elixir terminated unexpectedly

I’ve installed livebook by livebook_websetup.exe, but I can’t connect to Elixir runtime in livebook with Elixir Standalone on my Windows laptop.

once I click evaluate or Connect button, it shows:

Failed to connect runtime - Elixir terminated unexpectedly, please check the terminal for errors.

I don’t know what to do, I started it by clicking desktop ico…
Anyone can help? Any operations I should try or some settings I should check?

Well, the solution is change my Livebook installation path, because the old path has space :sweat_smile:

I am having the same issue. How do you change the path? Does it involve deleting the local repo and re-cloning?

Can you please open up an issue?

I fixed it by uninstalling and reinstalling again.

I get the same error.
Every time I try to evaluate a cell.
Where can I tail the logs? I couldn´t find anything related in /var/logs
I have reinstalled Livebook, but that made no difference.

I’m using LiveBook 0.11.14 on an Apple M2 Pro running on MacOS 13.0


For Windows users seeing this error, try re-installing as Administrator. Doing a regular install appears to work, but (for me at least) resulted in the termination error whenever I tried to connect to a notebook.