Localhost:4000/ not working on Chrome Browser

Generated a liveview elixir phoenix project and localhost:4000 doesn’t seem to work on chrome browsers. In FireFox and other browsers, the “/” endpoint works. How can I enable it to work on chrome browser because not users we have use Chrome as there default browser.

When using chome, the endpoint “/” brings an error saying the browser can’t connect to the service, and the application doesn’t show any logs, as if the “/” wasn’t hit. But for the specify a route eg “/log_in” thats when it works.

For other browsers, the application logs the “/” request and is able to response with the phoenix landing page.

Elixir version: Elixir 1.13.0 (compiled with Erlang/OTP 24)

Operating System: Ubuntu 20.04

Hi @ViperCoderJay . You will likely need to post some more information to help people answering your question. How are you running your application? What do you see in other browsers vs. what do you see on Chrome?

Usually, there is nothing special to be enabled on Chrome, and a LiveView application should work on any modern browser.

1 Like

and some have to make it work for IE11… :slight_smile:

1 Like

And for future users: …and some have to make it work for Chrome. Shoutout to y’all from the generation that wrestled IE for not obeying the standard!

Before anyone asks: For example Chrome’s implementation of Flexbox and how Youtube only worked smooth in Chrome as it used a Chrome specific instruction.

Having to support IE6 was the bomb (no jQuery) :sunny:

@ViperCoderJay maybe you have an extension in your Chrome browser which is causing problems? I would try it in incognito mode to make sure of that.

weird tho, im trying on my x240 thinkpad (ubuntu 20) chrome, brave and firefox seems ok (/ endpoint).

Some time is better work with the ip of the machine, like: