Missing phx tasks

Hi all
Have an umbrella app codebase I’ve been working with for a while now, and I’ve used phx tasks successfully in the past. Recently updated to phoenix 1.4.8. I tried running the phx.gen.context task, and got an error stating the task could not be found. I was in one of my phoenix web app directories when I tried this. I’ve also executed mix help | grep phx and all I get is:

$ mix help | grep phx
mix local.phx         # Updates the Phoenix project generator locally
mix phx.new           # Creates a new Phoenix v1.4.8 application
mix phx.new.ecto      # Creates a new Ecto project within an umbrella project
mix phx.new.web       # Creates a new Phoenix web project within an umbrella project

I’ve tried this in all app folders, root folders, mix clean, mix deps.clean, re-installed elixir, deleted the entire folder structure and restored from git, and still the same thing. Any ideas here? Don’t know what is missing at this point. Another dev in the same codebase gets all the phx tasks listed

Ok. Just tried a mix compile from the root directory, and all my tasks now show up :confused:
Good to go!