Mix command no output on windows 10

I have a machine running on windows 10 using elixir(1.8.1) and erlang(OTP 21).
When i run a mix commands related to web requests it runs but gives no output and just stops after about 20 seconds, after searching I’ve came across this issue Elixir #8252 that seems to be fixed on the version i am using.
Due to the lack of output i am left with no indication of the problem so i am looking for any suggestions to help me debug and fix this.
To add a little extra info:

  • No output
  • No deps are installed
  • No erros
  • Have tried a clean install,problem persists
  • mix deps.get and local.hex tested and not working for me

Any help would be appreciated, if any extra info is required i can provide it.
Thanks in advance

What’s the full output of elixir --version first of all?

Erlang/OTP 21 [erts-10.1] [64-bit] [smp:4:4] [ds:4:4:10] [async-threads:1]

Elixir 1.8.1 (compiled with Erlang/OTP 20)

Here is the output of elixir -v.

Could not find Hex, which is needed to build dependency :phoenix
Shall I install Hex? (if running non-interactively, use "mix local.hex --force") [Yn] Y

The output of mix deps.get.
Running mix local.hex --force gives no output
If i install hex manually by downloading the csv mix deps.get stops giving any output

I had the same problem. I still don’t understand what caused it, it’s really weird, but for what it’s worth: I had installed Erlang and Elixir on a brand new Windows computer using Scoop, and the problem described in this thread happened. Maybe you also used Scoop @AmadorZcv?

Anyway, I uninstalled both Erlang and Elixir using scoop, ran the Erlang installer from erlang.org, then the Elixir installer from elixir-lang.org, and then it worked. I do not understand why. I use scoop-installed Elixir/Erl on other computers.

(note: I know the Elixir installer can download and run the Erlang installer, but scoop had left some residue that made the Elixir installer think I had an Erlang even though I didn’t - hence the two separate steps)

I’m not sure whether the problem here is with scoop or with Elixir or something else. Scoop is usually admirably robust and non-messy.