Mix compile --profile time excludes file name

When I run the following I get:

λ mix compile --force --profile time
Compiling 592 files (.ex)
[profile]    142ms compiling +      0ms waiting for <redacted>
[profile]    145ms compiling +      0ms waiting for <redacted>
... etc

So I have no clue which file is being compiled… Which I thought the command used to do? I’m on elixir 1.13.0

If I remember correct, Elixir never redacted this information. Could your editor or something else be interfering?

Not as far as I can tell - I’ve tried with both iTerm2 and VSCode console, both under zsh and bash…
Also to clear any possible confusion I added the <redacted> to the output - that’s where there is a file name referencing what it’s waiting for - but I’m not seeing anything after [profile], which is where I expect the file name that’s being compiled to show up.

Also side-note: maybe part of the problem is that I can’t see the docs at https://hexdocs.pm/mix/1.13/Mix.Tasks.Compile.html to know if I’m using it correctly - I get a 404. I tried on 2 different networks. I got to that link from Mix.Task.Compiler — Mix v1.13.4 which maybe is just outdated? I seem to be getting a lot of 404’s coming from google now that I mention it.

Yeah, it should show the filename after the module name.