`mix escript.build` creating an archive file instead of an executable

Hello all! I’m (on Windows) trying to turn a mix project ( exe_example ) into an executable with mix escript.build at the root of the project. A file titled ‘exe_example’ is created, but whenever I tried to run it via .\ , double-click , etc. it just opens the binary file itself, instead of executing any instructions, so I’m just presented with symbols and gibberish. Curious, I checked the properties of the file that was being created, and it was listed as having only an ‘A’ attribute, meaning it is an archive file, not an executable. Trying to manually convert this archive file into an executable didn’t do the trick either. In addition, another oddity is that while the code is very small (just a sort of hello world cli program), the file ends up being about a megabyte size minimum, I assume this is elixir being embedded, or something else?

I’ve tried copying a few different tutorials online that were all essentially doing a basic cli program, and whenever I’ve gotten to the point of building the executable, I’ve run into this every time, and I’ve also tried on my laptop as well (also windows) and I had the same issue.

Has anyone else had this happen or otherwise might know a cause?

to run it, you need to run

escript exe_example

Assuming exe_example is the name of the compiled file.

It’s not a native executable, it’s more like a jar file from java. On windows, if you give the compiled file an extension you can associate that to be opened by escript automatically.

1 Like

Thank you, that worked. I’m assuming that’s purely a windows thing, as I’ve seen people running it with .\ on all the tutorials I’ve looked at. Most of the time I have no complaints about windows, but then there’s a lot of little things like this where I just feel like “why can’t you just be easy?”, like with the lack of something like chmod.

Actually they use ./<filename>, the forward slash is important, it’s not backslash. :slight_smile:

They reason why is that on both linux and mac (and ‘most’ things other than windows) when you ‘execute’ a file the kernel first checks if it has the executable bit set (chmod +x ... sets that), if so then it tests if it is an ELF format file and executes that (ELF is like Windows PE (*.exe) files but for other OS’s, it is super common), if it is not that then it tests if the first two characters in the file are #! and if it is then it takes whatever is after that up until the first newline (\n) and then ‘runs’ that program instead, passing this file ‘to’ that program.

Escript files have a #!elixir or something like that at the start, so running the file ./blah is like doing elixir ./blah, of which since # is the comment character in elixir it ignores that first line anyway, that’s actually why most ‘scripting’ formats use # as a comment indicator, because of that. :slight_smile:

Windows has nothing like that, you have to manually define mappings between weird things like the trailing extension and so forth. ^.^

Interesting, thank you for the help! Been wrestling with this for 3 days now o/

1 Like