'mix hex.outdated' tells the 'Update not possible' for some libraries

I want to update my APP for the course PhoenixLiveView with Pragmatic Studio and when I try to do a mix hex.outdated it complains Update not possible for some libraries as you can see:

$ mix hex.outdated
Dependency              Current  Latest  Status
ecto_sql                3.4.3    3.5.4   Update possible
faker                   0.14.0   0.16.0  Update not possible
floki                   0.26.0   0.29.0  Update possible
gettext                 0.17.4   0.18.2  Update possible
inflex                  2.0.0    2.1.0   Update not possible
jason                   1.2.2    1.2.2   Up-to-date
number                  1.0.1    1.0.3   Update possible
phoenix                 1.5.6    1.5.7   Update possible
phoenix_ecto            4.1.0    4.2.1   Update possible
phoenix_html            2.14.2   2.14.3  Update possible
phoenix_live_dashboard  0.2.10   0.4.0   Update not possible
phoenix_live_reload     1.2.1    1.3.0   Update possible
phoenix_live_view       0.14.7   0.15.4  Update not possible
plug_cowboy             2.4.0    2.4.1   Update possible
postgrex                0.15.3   0.15.8  Update possible
telemetry_metrics       0.6.0    0.6.0   Up-to-date
telemetry_poller        0.5.0    0.5.1   Update possible
timex                   3.6.2    3.6.3   Update possible

Run `mix hex.outdated APP` to see requirements for a specific dependency.

To view the diffs in each available update, visit:

I want to try the command mix deps.update.
But first I want to ask here how to properly update these libraries.
Someone can help me with this please?

1 Like

“Update not possible” mean that constraints in direct or indirect dependencies are preventing upgrade. For example if some library requires inflex =2.0.0 then there is nothing you can do unless that dependency updates their constraint. Of course you can override deps, but that can cause breakages in that dependencies due to incompatibility.

2 Likes

So If I update it’s possible to take errors.
So you recommend do nothing?
Or I need to read the evolution of the version library and make some changes?

For these… updating Phoenix to 1.5.7 should make them available for update

The command will consider the restrictions in your mix.exs file.

When you run mix dips.update --all, it will upgrade all versions labeled as “Update possible”.

For instance, say you have {:phx_gen_auth, "~> 0.5.0"} in your mix file.
After you run mix hex.outdated you’ll see:

Dependency              Current  Latest  Status               
phx_gen_auth            0.5.0    0.6.0   Update not possible  

In this case, the update is not possible because in the mix file you specifically restricted the upgrade to 0.5 versions, it would update to 0.5.x as 0.5.2 or 0.5.9 but it won’t upgrade to 0.6.x.

So you might want to relax your dependencies a little bit.

2 Likes

So I do a:

$ mix deps.update --all
Resolving Hex dependencies...
Dependency resolution completed:
Unchanged:
  combine 0.10.0
  cowboy 2.8.0
  cowlib 2.9.1
  faker 0.14.0
  html_entities 0.5.1
  inflex 2.0.0
  jason 1.2.2
  metrics 1.0.1
  mimerl 1.2.0
  phoenix_live_dashboard 0.2.10
  phoenix_pubsub 2.0.0
  plug_crypto 1.2.0
  ranch 1.7.1
  telemetry 0.4.2
  telemetry_metrics 0.6.0
Upgraded:
  certifi 2.5.1 => 2.5.3
  connection 1.0.4 => 1.1.0
  cowboy_telemetry 0.3.0 => 0.3.1
  db_connection 2.2.2 => 2.3.1
  decimal 1.9.0 => 2.0.0 (major)
  ecto 3.4.3 => 3.5.6
  ecto_sql 3.4.3 => 3.5.4
  file_system 0.2.8 => 0.2.10
  floki 0.26.0 => 0.29.0 (minor)
  gettext 0.17.4 => 0.18.2 (minor)
  hackney 1.15.2 => 1.17.0
  idna 6.0.0 => 6.1.1
  mime 1.4.0 => 1.5.0
  number 1.0.1 => 1.0.3
  parse_trans 3.3.0 => 3.3.1
  phoenix 1.5.6 => 1.5.7
  phoenix_ecto 4.1.0 => 4.2.1
  phoenix_html 2.14.2 => 2.14.3
  phoenix_live_reload 1.2.1 => 1.3.0
  phoenix_live_view 0.14.7 => 0.14.8
  plug 1.10.4 => 1.11.0
  plug_cowboy 2.4.0 => 2.4.1
  postgrex 0.15.3 => 0.15.8
  ssl_verify_fun 1.1.5 => 1.1.6
  telemetry_poller 0.5.0 => 0.5.1
  timex 3.6.2 => 3.6.3
  tzdata 1.0.3 => 1.0.5
  unicode_util_compat 0.4.1 => 0.7.0 (minor)
* Updating phoenix (Hex package)
* Updating phoenix_ecto (Hex package)
* Updating ecto_sql (Hex package)
* Updating postgrex (Hex package)
* Updating phoenix_live_view (Hex package)
* Updating floki (Hex package)
* Updating phoenix_html (Hex package)
* Updating phoenix_live_reload (Hex package)
* Updating telemetry_poller (Hex package)
* Updating gettext (Hex package)
* Updating plug_cowboy (Hex package)
* Updating number (Hex package)
* Updating timex (Hex package)
* Updating tzdata (Hex package)
* Updating hackney (Hex package)
* Updating certifi (Hex package)
* Updating idna (Hex package)
* Updating parse_trans (Hex package)
* Updating ssl_verify_fun (Hex package)
* Updating unicode_util_compat (Hex package)
* Updating decimal (Hex package)
* Updating cowboy_telemetry (Hex package)
* Updating plug (Hex package)
* Updating mime (Hex package)
* Updating file_system (Hex package)
* Updating connection (Hex package)
* Updating db_connection (Hex package)
* Updating ecto (Hex package)

and then:

mix hex.outdated
Dependency              Current  Latest  Status
ecto_sql                3.5.4    3.5.4   Up-to-date
faker                   0.14.0   0.16.0  Update not possible
floki                   0.29.0   0.29.0  Up-to-date
gettext                 0.18.2   0.18.2  Up-to-date
inflex                  2.0.0    2.1.0   Update not possible
jason                   1.2.2    1.2.2   Up-to-date
number                  1.0.3    1.0.3   Up-to-date
phoenix                 1.5.7    1.5.7   Up-to-date
phoenix_ecto            4.2.1    4.2.1   Up-to-date
phoenix_html            2.14.3   2.14.3  Up-to-date
phoenix_live_dashboard  0.2.10   0.4.0   Update not possible
phoenix_live_reload     1.3.0    1.3.0   Up-to-date
phoenix_live_view       0.14.8   0.15.4  Update not possible
plug_cowboy             2.4.1    2.4.1   Up-to-date
postgrex                0.15.8   0.15.8  Up-to-date
telemetry_metrics       0.6.0    0.6.0   Up-to-date
telemetry_poller        0.5.1    0.5.1   Up-to-date
timex                   3.6.3    3.6.3   Up-to-date

Sorry guys, what I need to do now?
The path for the commands to update was ok?
So now how I need to do for upgrade the phoenix_live_view?

Sorry I was wrong and You also need to change your versions in mix.exs as well, as mentionned by @shamanime

Try to change your mix.exs to

dashboard → 0.4
live_view → 0.15

then mix deps.get and mix compile…

4 Likes

This link Version — Elixir v1.11.3 has a little bit more information about what the symbols before the versions specified in the mix.exs file do.

When I changed these versions for {:phoenix_live_view, "~> 0.15.4"}, {:phoenix_live_dashboard, “~> 0.4.0”}`` ElixirLS tells this error on Visual Studio Code:

an exception was raised:
    ** (Mix.Error) Can't continue due to errors on dependencies
        (mix 1.11.2) lib/mix.ex:436: Mix.raise/1
        (mix 1.11.2) lib/mix/tasks/deps.loadpaths.ex:28: Mix.Tasks.Deps.Loadpaths.run/1
        (mix 1.11.2) lib/mix/task.ex:394: Mix.Task.run_task/3
        (mix 1.11.2) lib/mix/tasks/loadpaths.ex:37: Mix.Tasks.Loadpaths.run/1
        (mix 1.11.2) lib/mix/task.ex:394: Mix.Task.run_task/3
        (mix 1.11.2) lib/mix/tasks/compile.ex:113: Mix.Tasks.Compile.run/1
        (mix 1.11.2) lib/mix/task.ex:394: Mix.Task.run_task/3
        (language_server 0.6.4) lib/language_server/build.ex:199: ElixirLS.LanguageServer.Build.compile/0ElixirLS
Peek Problem (⌥F8)
No quick fixes available

So I tried to update even with those errors doing mix deps.get and mix compile…
It was needed to restart the ecto and the app phoenix liveview are working right and passing the tests.
But The ElixirLS continues raising this error…

Thank you all for the help, it was very helpfull!

I have bad experienced with vscode aggressively changing my dependencies.

Now, I stop vscode and use vim when I update.

Try removing .elixir_ls/ manually, it will be rebuilt next time You open vscode.

Try removing _build and recompile.

I know a little bit Vim but I need to learn more…
Wich libraries are recommended for elixir?
I have in my plans to read some book…

So I deleted and the errors continue but it’s working the app and the tests pass.

The auto fetching of deps can be disabled in the settings.

2 Likes

Nice, thank you @LostKobrakai!