Mix warning won't resolve

I’m still getting "a previous clause at line 1 always matches" warning below, even though I long ago removed the .ex file that was re-defining the problematic DefineMessage module from exprotobuf:

> mix deps.compile
> mix compile

==> my_app
Compiling 13 files (.ex)
warning: this clause cannot match because a previous clause at line 1 always matches
  lib/exprotobuf/define_message.ex:1

This was indeed a valid warning for this project, as it used to contain a same-named module DefineMessage. The module was in a file under config/, and on deployment it would overwrite exprotobuf's own module: we’d literally do

cp config/our_define_message.ex  \
  deps/exprotobuf/lib/exprotobuf/define_message.ex

A similar issue on GitHub was supposedly already resolved.

In despair, grep from the project root, with grouped output between .elixir_ls/, _build/ and deps/:

> grep -R DefineMessage .

Binary file ./.elixir_ls/dialyzer_tmp/.elixir_ls/build/_test/lib/exprotobuf/ebin/Elixir.Protobuf.Builder.beam matches
Binary file ./.elixir_ls/dialyzer_tmp/.elixir_ls/build/_test/lib/exprotobuf/ebin/Elixir.Protobuf.DefineMessage.beam matches
./.elixir_ls/build/_test/lib/exprotobuf/ebin/exprotobuf.app:                        'Elixir.Protobuf.DefineMessage',
Binary file ./.elixir_ls/build/_test/lib/exprotobuf/ebin/Elixir.Protobuf.Builder.beam matches
Binary file ./.elixir_ls/build/_test/lib/exprotobuf/ebin/Elixir.Protobuf.DefineMessage.beam matches

Binary file ./_build/dev/lib/my_app/.mix/compile.app_tracer matches

./_build/dev/lib/exprotobuf/ebin/exprotobuf.app:                        'Elixir.Protobuf.DefineMessage',
Binary file ./_build/dev/lib/exprotobuf/ebin/Elixir.Protobuf.Builder.beam matches
Binary file ./_build/dev/lib/exprotobuf/ebin/Elixir.Protobuf.DefineMessage.beam matches

grep: ./deps/setup/xtest/testapp-2/rebar: No such file or directory
grep: ./deps/setup/xtest/testapp-1/rebar: No such file or directory

./deps/exprotobuf/lib/exprotobuf/define_message.ex:defmodule Protobuf.DefineMessage do
./deps/exprotobuf/lib/exprotobuf/builder.ex:  import Protobuf.DefineMessage, only: [def_message: 3]

Any ideas where the issue might lie much appreciated.

Try
$ mix clean

before

$ mix compile

Thanks for the suggestion. Alas, neither mix clean nor mix clean --deps worked.

mix clean --deps seems to delete _build/$MIX_ENV. I even tried rm -rf deps/ _build/ before in vain. Open to further suggestions, I need to get rid of this last warning.

PS. Recloned the project, ran rm -rf .git _build deps and recompiled. Still, the warning persists.

Maybe unrelated, but even with elixir set to 1.10.4 via asdf

$ asdf install
elixir 1.10.4-otp-23 is already installed
erlang 23.1 is already installed

elixir --version still returns 1.11.2.

$ elixir --version  
Erlang/OTP 23 [erts-11.1] [source] [64-bit] [smp:8:8] [ds:8:8:10] [async-threads:1] [hipe]

Elixir 1.11.2 (compiled with Erlang/OTP 23)

Maybe you’ve installed something as a global archive? Also something appears to be incorrect in your asdf setup if the incorrect version is being used. Does asdf current also show 1.10.4? What does which -a elixir show?

Thanks for the help Jason. I’ve looked further into both areas you mention, global archives and asdf.

Global archive

I think these are the only global archives.

$ ls ~/.mix/archives
hex-0.20.1           hex.ez        phoenix_new-1.1.2.ez   phx_new-1.4.10

asdf v0.8.0

asdf current looks ok.

$ asdf current
elixir          1.10.4-otp-23   ~/my_app/.tool-versions
erlang          23.1            ~/my_app/.tool-versions

List of all elixir executables ok as well.

$ which -a elixir
~/.asdf/shims/elixir
/usr/local/bin/elixir

And the content of the above shim.

#!/usr/bin/env bash
# asdf-plugin: elixir
exec /usr/local/opt/asdf/bin/asdf exec "elixir" "$@" # Running this with "--version" arg does return 1.11.2 though

Worth noting that I also ‘fixed’ the syntax error before: "$@" issue with asdf’s mix shim and changed ~/.asdf/shims/mix from

#!/usr/bin/env bash
# asdf-plugin: elixir
exec /usr/local/opt/asdf/bin/asdf exec "mix" "$@"

to a ‘working’ version.

#!/usr/bin/env elixir
Mix.start
Mix.CLI.main

I’ve had this happen quite a bit and removing the ElixiLS directory always resolves it.

rm -rf ./.elixir_ls

Thanks. Alas, even

rm -rf .elixir_ls deps _build
mix deps.get
mix compile

didn’t resolve this warning.

Can you share the project or a project that reproduces the issue so that we can take a look?

Yes, will try to reproduce in a sample project. If that fails, I’ll try to get an approval from the stakeholders.

I’m having a similar issue with one of my projects, where one of the types modules for Absinthe, is returning me this error:
erorr

I have tried all the steps mentioned above, but the error persists.

Same issue here on the Types GraphQL module (use Absinthe.Schema.Notation).

FWIW this turned out to be because we were accidentally defining a field twice with the same name.

2 Likes