Newly installed Elixir version on Windows not found... Defaults to old version previously installed via chocolatey?

I’m still relatively new to Elixir and programming in general, so apologies if this is a basic mistake.

I am trying to upgrade to Elixir 1.13.2 (and then also will upgrade Phoenix and LiveView) on Windows.

N.B. - I’ve tried this on two different Windows 10 machines, both had Elixir originally installed via chocolatey. Both machines got the same result when trying to install with the web installer, as described below.

Previously, I used chocolatey as recommended - but their latest version (the one sat on my machine) is well out of date - 1.11.2.

So, instead, I used the web installer for Windows

Clicked through the recommended settings, and it seemed to have installed fine. And indeed, the little Erlang-Elixir emulator app is present, and when you run it, it shows Elixer v. 1.13.2.

But in my Windows PowerShell, elixir -v still says 1.11.2?? I tried uninstalling Elixir via chocolatey, and reinstalling via the web installer. This time, PowerShell doesn’t detect Elixir at all? Other attempts to coax the elixir version out of it, or use it all say that the latest version is that which chocolatey installed ages ago.

So, it seems to be using whatever chocolatey has done as the law, and ignoring whatever the web installer has done, even though it does seem to have installed something - put all the files on the system, the emulator app works, etc.

I must be doing something wrong/not understanding a basic thing about installing things, since it’s happened on two separate Windows machines?

But I’ve googled a lot, and come up with nothing. In the meantime, I’m totally stuck and can’t move forward.

Any help you could give thus would really be appreciated!

Thanks very much, indeed

Looking at the sequences in the installer, it seems to want to install a folder in C:\Program Files called erl10.7

There is already a folder there called erl10.5, which dates back to 2019. I’m guessing this was put there by chocolatey (but can’t be sure)? If I delete erl10.5 and do elixir --version, it throws this error:

Cannot find file at ‘c:\program files/erl10.5/erts-10.5/bin/erl.exe’ (c:\program files\erl10.5\erts-10.5\bin\erl.exe). This usually indicates a missing or moved file.

Even though erl10.7 is there - if that’s any further clue/confirmation as to what’s happening. Thanks again!