Nitpick: confirm_changeset should be renamed to confirmation_changeset

Looking at the generated code, there’re email_changeset and other <noun>_changesets. Hence, for consistency, confirm_changeset should be renamed (in the generators) to confirmation_changeset.

Confirm = verb
Confirmation = noun

Its @doc should also be aligned with other _changesets to, f.e.:

A user changeset for changing the time of confirmation.


I can see how it is an improvement. Did you consider sending a PR to help out? It’s usually easier and more time efficient for maintainers to accept and merge small changes like these than it is to do it themselves. :slight_smile:

1 Like