No preset version installed for command livebook

I have recently update my elixir version to 1.13.2-otp-24 through asdf.

On trying to run a livebook, it told me no livebook was found
so i ran

mix escript.install hex livebook 

which printed a warning that an old livebook variable in my path is overwritten,
cause I had previously added livebook when I was running the older elixir version.

Running the server

livebook server

results in

No preset version installed for command livebook
Please install a version by running one of the following:

asdf install elixir 1.13.2-otp-24

or add one of the following versions in your config file at ~/.tool-versions
elixir 1.12.2-otp-24

That is odd, cause checking the elixir version returns

git:(master) ✗ asdf which elixir
~/.asdf/installs/elixir/1.13.2-otp-24/bin/elixir

which should be perfectly fine.

Something is probably misconfigured, but I am not sure what it is.
Do you have an idea?

Have you tried a opening a new shell? You may have to run asdf reshim?

3 Likes

Yes I reopened the terminal.
asdf reshim was the solution, thanks.

2 Likes