Not able to connect MongooseIM in localhost

I built MongooseIM on my Mac, ping shows pong, mongooseimctl can create user.
But if I try to connect from any XMPP client like PSI/Jitsi, not able to connect, here is the error msg from XML debug:

<?xml version="1.0"?>

<stream:stream xmlns:stream="" version="1.0" xmlns="jabber:client" to="localhost" xml:lang="en" xmlns:xml="">

<?xml version='1.0'?><stream:stream xmlns='jabber:client' xmlns:stream='' id='4FFE641CC44D0B85' from='localhost' version='1.0' xml:lang='en'>

<starttls xmlns="urn:ietf:params:xml:ns:xmpp-tls"/>
<mechanisms xmlns="urn:ietf:params:xml:ns:xmpp-sasl">
<register xmlns=""/>
<sm xmlns="urn:xmpp:sm:3"/>

<starttls xmlns="urn:ietf:params:xml:ns:xmpp-tls"/>

<proceed xmlns="urn:ietf:params:xml:ns:xmpp-tls"/>

Anybody any idea?

This is not an error message but the normal protocol to connect to the xmpp server. It enumerates the authentication modes that are supported by MongooseIM and says that you can also register, i.e. create an account.

I already created account, but still not able to connect.
I checked the logs, looks like need to configure a bunch of certificates in order to connect. not because localhost can omit anything.

@ejabberd_c2s:process_terminated/2:312 (tls|<0.538.0>) Failed to secure c2s connection: TLS failed: Failed to find a certificate matching the domain in SNI extension: error:1422E0EA:SSL routines:final_server_name:callback failed

Any idea?

You can try to disable TLS in your client. Make sure that MongooseIM accepts non secured connection and that your client connects to the right port. There is a config file in MongooseIM for setting the ports it should listen to.

thank you, works. the trick is disable secure in client in any place, in my case PSI works, in two places.

Jitsi still not working. anyway, server works :slight_smile: