Passed flag has no effect in elixir-pdf-generator


I am using elixir-pdf-generator,
and it has been working great so far, but my docker image has been updated, and cannot set it to the old digest(elixir@sha256:d01bf3cfcea150f71fc8f729bfda0ee55b44379aa782b1221acce269ddcbe411) - this digest worked 2 days ago but not anymore…
It is an alpine image, locally on ubuntu in the container everything works.

Anyway it broke wkhtmltopdf(got updated to 0.12.6) and gives an error that says:

(MatchError) no match of right hand side value: {:error, {:generator_failed, "QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'

Now through my research I found that this issue could be solved by passing this


flag to wkhtmltopdf.

You are supposed to be able to pass flags throught shell_params in the pdf generator but it does not take effect.
I tried to pass it as a string and as a list of one string.

Any ideas foe either of the 2, or similar experience?

Update by adding


To the yml this error is gone, but there is a new one:

(MatchError) no match of right hand side value: {:error, {:generator_failed, "Loading page (1/2)\n[> ] 0%\r[==============> ] 24%\r"}}

This was there before too just the XDG_RUNTIME_DIR related part is gone.

Some more logs here: