Phoenix does not support poison 3.0

Hi all
I want to use the poison 3.0 on my phoenix app based on version 1.2.1 and added to mix.exs.
When I want to get the dependency with mix deps.update then it shows me:

Failed to use "poison" (version 3.0.0) because
  phoenix (version 1.2.1) requires ~> 1.5 or ~> 2.0
  mix.exs specifies ~> 3.0

How to make phoenix compatible to poison 3.0?

Thanks

3 Likes

Hmm, could override it, but that still leaves a question of if phoenix would work. Do you know what changes were made from Poison 2 -> 3?

1 Like

Not at all. I do not know, if there a big changes or not.

Hmm, they don’t have a changelog or describe the changes in the readme or so, unsure myself… Try overriding it and see if anything breaks?

{:poison, "~> 3.0", override: true} # Something like this?
6 Likes

Yes, it accepted. Now I have to test, if it works or not.

Thanks so much.

1 Like

Yes, the changes in Poison 3.0 did not affect Phoenix. Phoenix master also supports Poison 3.0, here is the commit: https://github.com/phoenixframework/phoenix/commit/655f45bf9cf6cc0b1d85af3d1c9c43afbcacaf1a

6 Likes