Phoenix error while adding xandra library to dependencies

i have created new phoenix app with mix command and added PETAL stack every thing was working fine but my company requirement is to use cassandra DB, so added xandra package to dependencies and ran mix deps.get command and i’m getting these errors

ambi@av blockchain-pos % mix deps.get
Resolving Hex dependencies...

Failed to use "decimal" because
  absinthe (version 1.6.4) requires ~> 1.0 or ~> 2.0 *
  jason (version 1.2.2) requires ~> 1.0 or ~> 2.0 *
  postgrex (version 0.15.9) requires ~> 1.5 or ~> 2.0 *
  xandra (version 0.13.1) requires ~> 1.7 *
  mix.lock specifies 2.0.0

* This requirement does not match pre-releases. 
To match pre-releases include a pre-release in the requirement, 
such as: "~> 2.0-beta".

** (Mix) Hex dependency resolution failed, change the version 
requirements of your dependencies or unlock them (by using mix 
deps.update or mix deps.unlock). If you are unable to resolve the 
conflicts you can try overriding with {:dependency, "~> 1.0", override: true}

if I remove xandra from dependencies no errors
my doubt is, is the xandra conflicting with ecto? or some thing else

any help would be appreciated

I think if you do:

mix deps.unlock decimal
mix deps.get

You should be ok. The message mix.lock specifies 2.0.0 says that the version is locked to 2.0.0 so you need to unlock that so dependency resolution can run again.


thank you @kip it worked