Phoenix install is crashing

I’m getting a slew of mysterious nastygrams when I try to install Phoenix:

Suggestions, anyone?


$ mix archive.uninstall phx_new
$ mix archive.install hex phx_new 1.4.0

I tried that, but it blew up in a slightly different way:


I am glad you got Phoenix 1.4 installed! :smiley:

It appears an issue with node/webpack is going on here. What version of node do you have installed?

$ node -v

$ node -v


That seems a bit dated; how would I upgrade?

I think we solved your problem :grinning: Node 5.0.0 or greater is required. Can you confirm you are using a macOS?

If you are using macOS, I am partial to using Homebrew:

If not already installed via Homebrew:

$ brew install node
🍺  /usr/local/Cellar/node/11.2.0

To upgrade if already installed via Homebrew:

$ brew upgrade node
node 10.11.0 -> 11.2.0

Neither Homebrew nor ports shows node as being theirs, so I tried a recipe I found on StackOverflow. Sadly, it also failed:

Since I have no idea how node was installed, I’m not at all sure how to clear it out. Sigh…

Did you try brew install node? You should be able to install node via Homebrew.

Seems like I’d need to clear out the old version first…

FWIW, it seems to be installed thusly:

$ ls -al /usr/local/bin/n

lrwxr-xr-x 1 root admin 27 Nov 16 21:28 /usr/local/bin/n@ -> …/lib/node_modules/n/bin/n

So, I removed …/node_modules and am trying brew.

That seems to have installed, so I’m retrying the Phx install from scratch.

That succeeded. Thanks for the help!


@Rich_Morin sorry for the late reply. I’ve been hanging out with my kids all day. I’m excited you have successfully setup your Phoenix project. I (as well as a bunch of helpful people here) am always willing to help out.