Phoenix LiveView Unchecked runtime.lastError

Hi, I get this error in my LiveView project, after working for a while or leaving a project for minutes I get this error in my browser console:

Unchecked runtime.lastError: Could not establish connection. Receiving end does not exist.

It does not break my project and after getting this error it works if I do another action.

How can I fix this, I need to send an interval?

It should be noted, I am in development mode.

Thank you in advance

Try disabling browser extensions by running in private mode to see if that is the issue.

1 Like

I tried before, I send something like this in mount:

if connected?(socket), do: Process.send_after(self(), :update, 30000)

Still, I did not get the error.

I mean open your chrome browser in anonymous mode and see if you still get the error. I’m suggesting that there is a browser extension causing the hiccup.

Are you saying you alley identified that as the issue and are more trying to account for interruptions?

1 Like

Yes, I have already applied the things you said. I don’t have any add-on active on the browser and I used the private mode of the browser, there was an error.

I don’t know, but it helps make more time to get this error, not fix this. I think the websocket channel should be closed like user session after login.

I do not know I am right or not!


I think I have a problem in my network!! not about liveview