Phoenix server has stopped, no errors given

my server just stopped running and when i tried to restart it (iex -S mix phx.server) my interactive shall starts but the server isnt starting

ive tried deleting dependacies and getting them again nothing has helpped out

What does it print when trying to start?

1 Like

Nothing, i am not getting any message in my console.
i have a Genserver which is the only thing showing

To clarify, by “console” I mean "right below where you type in iex -S mix phx.server" (not the browser console). Since you mention the interactive shell starting, I presume there’s the BEAM startup banner similar to:

Erlang/OTP 23 [erts-11.1] [source] [64-bit] [smp:72:72] [ds:72:72:10] [async-threads:1] [hipe]

Interactive Elixir (1.11.2) - press Ctrl+C to exit (type h() ENTER for help)

followed by application-specific startup messages.

I’m not understanding what’s meant by “showing” here; does the GenServer print a message?

Hum, never have things like that, so maybe I’ll be totally out of the place.

Maybe check the supervisor is been called and the cowboy server is been started.

delete _build, deps, assets/node_modules and then

$ mix deps.get
$ mix compile
assets $ npm install

if its still not working, check if a completely new phoenix project works.


i actually just created a new project and moved my functionality and stuff and its running perfectly