Problems upgrading to Elixir 1.7 using Phoenix on a Mac

I upgraded from Elixir 1.6.1 to Elixir 1.7.2 by entering

brew upgrade Elixir

from the command line on a Mac Air.

I then tried to run ‘mix test’ for my project, and go a lot of error messages, and no tests:

=SUPERVISOR REPORT==== 12-Aug-2018::22:37:24.890792 ===
    supervisor: {local,'Elixir.Logger.Supervisor'}
    errorContext: start_error
    reason: noproc
    offender: [{pid,undefined},
=CRASH REPORT==== 12-Aug-2018::22:37:24.890601 ===

mix phx.serve" produced the same errors, and wouldn’t run the web app I’d developed under 1.6.

ls /usr/local/Cellar/elixir/


1.3.2 1.5.2 1.6.1 1.7.2

so I entered

brew switch elixir 1.6.1

to go back to Elixir 1.6.1.

But when I run the app, it has the same issues:

=CRASH REPORT==== 12-Aug-2018::22:53:09.095319 ===
    initial call: application_master:init/4 ** (MatchError) no match of right hand side value: {:error, {:logger, {{:shutdown, {:failed_to_start_child, Logger.ErrorHandler, :noproc}}, {Logger.App, :start, [:normal, []]}}}}


The web app was working before I tried to upgrade Elixir.

What is your Erlang/OTP version?

Erlang/OTP 21 [erts-10.0.4] [source] [64-bit] [smp:4:4] [ds:4:4:10] [async-threads:1] [hipe] [dtrace]

Eshell V10.0.4


Got it:
λ brew upgrade erlang
λ elixir -v
Erlang/OTP 21 [erts-10.0.5] [source] [64-bit] [smp:4:4] [ds:4:4:10] [async-threads:1] [hipe] [dtrace]
Elixir 1.7.2 (compiled with Erlang/OTP 21)

Now my code works - with pages of warnings when I compile and run it. Thanks, Jose.