Problems with wallaby + chrome + travis ci

I am currently trying to update a hobby project of mine ( that has some really outdated code in it. To do it safely I want to add some more tests using wallaby to make the refactoring save. Currently the app is using phantomjs, but I want to switch using chrome(ium) but haven’t found a way that actually works on travis ci.

The .travis.yml I am using can be found here .

Locally it works just fine, but on Travis it fails with:

 ** (RuntimeError) invalid session id
     code: |> visit("/")

       (wallaby) lib/wallaby/httpclient.ex:136: Wallaby.HTTPClient.check_for_response_errors/1
       (wallaby) lib/wallaby/httpclient.ex:56: Wallaby.HTTPClient.make_request/5
       (wallaby) lib/wallaby/experimental/selenium/webdriver_client.ex:254: Wallaby.Experimental.Selenium.WebdriverClient.visit/2
       (wallaby) lib/wallaby/driver/log_checker.ex:6: Wallaby.Driver.LogChecker.check_logs!/2
       (wallaby) lib/wallaby/browser.ex:963: Wallaby.Browser.visit/2
       test/sign_dict_web/features/entry_voting_test.exs:17: (test)

See here for the full output.

I tried a lot, but I now need some help. There is an open issue on Wallaby that hints to the amount of threads, but I also tried to limit the number of simultaneous tests to 1 and it still failed. Does someone here has it working in a project? If yes, can that person share the config file? That would be awesome.

1 Like

On Travis the installed chromedriver might have different version than Wallaby requires.

1 Like