[programming phoenix] could not fetch application environment :wolfram

Error message from the iex:

iex(2)> [error] Task #PID<0.385.0> started from #PID<0.382.0> terminating
** (ArgumentError) could not fetch application environment :wolfram for application :rumbl because configuration :wolfram was not set

The book says:

Visit the WolframAlpha developer portal, 2 sign up for a
new account, and follow the instructions to get your AppID.

Now that you have a developer API key, you could place it directly in config/dev.exs , but there’s a better way. You shouldn’t check in private credentials under version control. In fact, Phoenix points you in the right direction with the generated config/prod.secret.exs file. That file references environment variables that are securely set on the production server, meaning you can establish sensitive configuration in your local development environment without checking secret values into version control. That way you can include sensitive credentials properly. Let’s add our API key lookup to our development and prod environments. Since tests will not hit the Wolfram API directly, we don’t need to set a key for that environment. Add the following entry to your config/dev.exs and config/prod.secret.exs like this:

wolfram_app_id =
  System.get_env("WOLFRAM_APP_ID") ||
  raise """
  environment variable WOLFRAM_APP_ID is missing.
  """
config :info_sys, :wolfram, app_id: wolfram_app_id
  1. The book says to get the api key from WolframAlpha. But later in the code example the api key is not used.
  2. It says:

In fact, Phoenix points you in the right direction with the generated config/prod.secret.exs file

But in fact, there was no file like that.

  defp id, do: Application.fetch_env!(:rumbl, :wolfram)[:app_id]

It is from wolfram.ex
I think the problem is here. But I don’t know what to do here.

Hi,
What version of programming phoenix are you using?

The solution was ridiculously simple, I changed :rumbl to :info_sys and everything worked:


  defp id, do: Application.fetch_env!(:info_sys, :wolfram)[:app_id]

Phoenix v1.4.2

Thanks but i was asking about the book version.

Programming phoenix 1.4 or Programming phoenix 1.3?

In any case glad that you solved your problem.

Programming phoenix 1.4, beta 10.

OK,

I use version Programming phoenix 1.4 1.0p