Protocol.UndefinedError only while running tests.


I’m currently running into this error when trying to run mix test. Compiling and running has no problem. I’ve tried with 1.11.4 and 1.12 to no avail. I’m running with OTP 23 (NixOS).

== Compilation error in file lib/gettext/compiler.ex ==
** (Protocol.UndefinedError) protocol Enumerable not implemented for :debug of type Atom
    (elixir 1.12.0) lib/enum.ex:1: Enumerable.impl_for!/1
    (elixir 1.12.0) lib/enum.ex:141: Enumerable.reduce/3
    (elixir 1.12.0) lib/enum.ex:403: Enum.any?/2
    (logger 1.12.0) lib/logger.ex:911: Logger.macro_log/4
    (logger 1.12.0) expanding macro: Logger.error/1
    lib/gettext/compiler.ex:356: Gettext.Compiler.warn_if_domain_contains_slashes/1
    (elixir 1.12.0) expanding macro: Kernel.if/2
    lib/gettext/compiler.ex:355: Gettext.Compiler.warn_if_domain_contains_slashes/1
could not compile dependency :gettext, "mix compile" failed. You can recompile this dependency with "mix deps.compile g
ettext", update it with "mix deps.update gettext" or clean it with "mix deps.clean gettext"

I’ve tried removing the _build and deps folder to no avail. I’ve also tried doing mix deps.compile gettext but I guess this isn’t the same as when running tests.

Thank you.