"Random" compilation errors when importing modules

Hi all,

I’m taking the Elixir/OTP course over at Developing With Elixir/OTP (Pragmatic Studio). When I run my file with elixir <path-to-file> all is well. However, I defined a module and ran iex -S mix and after that, the compiler throws errors saying the module cannot be imported. I rolled the code back and the error persists. I deleted the _build directory with no success. The module is defined in plugins.ex as follows:

defmodule Servy.Plugins do
  import Logger

  def rewrite_path(%{path: "/wildlife"} = conv) do
      %{ conv | path: "/wildthings" }

  def rewrite_path(%{path: path} = conv) do
      regex = ~r{\/(?<thing>\w+)\?id=(?<id>\d+)}
      captures = Regex.named_captures(regex, path)
      rewrite_path_captures(conv, captures)

  def rewrite_path(conv), do: conv

  def rewrite_path_captures(conv, %{"thing" => thing, "id" => id}) do
      %{ conv | path: "/#{thing}/#{id}" }

  def rewrite_path_captures(conv, nil), do: conv

  def log(conv) do
      Logger.info "Inspecting conversation map..."
      IO.inspect conv

  def track(%{status: 404, path: path} = conv) do
      IO.puts "Warning: #{path} is on the loose!"

  def track(conv), do: conv

and it is imported in handler.ex as follows:

defmodule Servy.Handler do
	@moduledoc "Handles HTTP requests."

  @pages_path Path.expand("../../pages", __DIR__)

  import Servy.Plugins, only: [rewrite_path: 1, log: 1, track: 1]

Any ideas what’s going on?


Update: when I run rm -rf _build in my project home directory, and then I run iex -S mix, the app is recompiled successfully and I can import all modules in iex. However, running a standalone file using elixir path/to/file still produces the error “** (CompileError) lib/servy/handler.ex:6: module Servy.Plugins is not loaded and could not be found”

Any ideas as to what’s going on?

You shouldn’t execute files as scripts using elixir when you are inside a mix project. mix has all the context of your project files and will automatically compile and load the files in it, elixir on the other hand only knows about the files you pass to it directly on the command line, that’s why it cannot find the Servy.Plugins module.

To run the code inside your project you should use iex -S mix like you already do or using the mix run task.


Thank you, this did solve the issue. I also double-checked the video lesson and found a rather similar explanation.

I’m glad that this turned out to be a PEBKAC and not worse.