Renaming and splitting packages in hex

I have worked a lot on my myspace_ipfs package and I am ironing out the creases. But learning Elixir and making a package this big was not so smart.
The quality has become OK and I find it good enough to qualify for a smaller namespace name, eg. ex_ipfs.

But it is too big. (And the name is too long). There are just to many tests to be written, so I’ve lost some momentum. I use the core parts myself and find that I like them. So I thought to relaunch the core parts as
and then add sub packages like

Or something to that effect. How does the community feel about renaming packages (and thus polluting the name space). And what is the general feeling about splitting packages up into smaller parts?


Well, just try to search for opentelemetry on and you’ll see that your example is very tame. :003:

In short: that’s absolutely fine, as long as you don’t drown in complexity of project A depending on B depending on C depending on A etc. That’s one type of complexity that kills motivation (and time, and energy).

1 Like

Sometimes it’s for the better. Especially as it allows other developers to onboard by starting a subpackage/extension.

1 Like

Indeed. The Core Module should be the only dependency. I did the opentelemetry search :smiley:

And the pubsub for example is experimental and could possibly be made obsolete any day of the week. IPFS itself is a highly volatile target.

Their way of creating a API for the command line app to mostly use is a very good idea. Although sometimes confusing as they confuse what is command line args and what is API args. So things change quickly. But, boy is it fun and exciting.