Replacing escape characters

I want to String.replace(string, "\", "") a string that looks like this "{\"year\":\"2020\",\"p\":\"1002\"}" but it doesnt work.
How can I remove the \ character from this string.

1 Like

There is no backslash in the string.

The \" combination is used to “escape” the doublequote to be able to use it in the string.

If you were writing "{"year":"2020"}" it where a syntax error, as there is no operator between "{" and the variable year, etc.

If you were printing the string "{\"year\":\"2020\",\"p\":\"1002\"}" you’d see {"year":"2020","p":"1002"}.


I am posting that tuple to a web service that seems to be getting \ literally, instead on escaping it like you have said,.

How do you post it and what makes you think it were receiving those literally?

1 Like

I am using HTTPoison which returns 400,
Tried calling the endpoint with that very string in postman it returns 400 as well, unless without the \ involved in the query string so i assumed its taking them in literally.

Again, when you see "\"" in the REPL/iex then the string contains only a single double quote. Of course when you copy the inspected value and paste it as is into some other program that interpretes input as is, then it will go wrong, as both programs work with different levels of abstractions.

Thats why I’m asking how exactly you are testing that the receiver sees the actual backslash.

An!("", "{\"year\":\"2020\",\"p\":\"1002\"}") will issue an HTTP post request with the following body:


You can verify using wireshark or tcpdump or any other network sniffer if you want (and are not using HTTPS).

Also I assume, that when the other side returns a 400, then it usually tells you in the body or the headers what you did wrong.

Therefore again, please show us the code how you send the request via HTTPoison and how you do via postman. Please include what headers you send from the postman side.


It is not actually in your string anywhere. The backslash is used to escape double quotes (") in the code. Try this for yourself:


It prints a double quote ("). The backslash tells the compiler: what follows is the special character ".

This is invalid code. The valid code is:

String.replace(string, "\\", "")

But that is not needed in your case. Try this:

"{\"year\":\"2020\",\"p\":\"1002\"}" == ~s({"year":"2020","p":"1002"})

The backslashes you might see in the console are just instructions that what follows is an otherwise special character. If this confuses you then you should read up on special characters and escaping.

This image applies to Python and not Elixir but it has a lot in common with it. Hopefully it unlocks your understanding.


@dimitarvp and @NobbZ,

Thanks for your help,
The problem was never the escape character \
I wasn’t passing the Content-Type in my headers list for the request.
Now solved.!

1 Like