Running a Phoenix application on a read-only filesystem

I am trying to build a Phoenix application for Sandstorm. Sandstorm runs instances of applications in containers, grains, that all have a read-only filesystem. The only writeable directory is /var.

In order to prepare a grain a few scripts are run:,, and is in charge of installing all the necessary dependencies in a VM to setup your development environment. prepares the sources for your application. starts the actual grain.

In my I simply run MIX_ENV=prod mix compile to build my application. in I start it with MIX_ENV=prod PORT=4000 mix phx.server.

When trying to start the application I get the following log output:

    Compiling 5 files (.ex)
    warning: redefining module HistorianWeb.PageController (current version loaded from _build/prod/lib/historian/ebin/Elixir.HistorianWeb.PageController.beam)

    warning: redefining module HistorianWeb.Gettext (current version loaded from _build/prod/lib/historian/ebin/Elixir.HistorianWeb.Gettext.beam)

    warning: redefining module HistorianWeb.ErrorView (current version loaded from _build/prod/lib/historian/ebin/Elixir.HistorianWeb.ErrorView.beam)

    warning: redefining module HistorianWeb.LayoutView (current version loaded from _build/prod/lib/historian/ebin/Elixir.HistorianWeb.LayoutView.beam)

    warning: redefining module HistorianWeb.PageView (current version loaded from _build/prod/lib/historian/ebin/Elixir.HistorianWeb.PageView.beam)

    ** (File.Error) could not write to file "/opt/app/_build/prod/lib/historian/ebin/Elixir.HistorianWeb.PageView.beam": read-only file system
        (elixir) lib/file.ex:953: File.write!/3
        (mix) lib/mix/compilers/elixir.ex:560: anonymous fn/4 in Mix.Compilers.Elixir.write_manifest/5
        (elixir) lib/enum.ex:1925: Enum."-reduce/3-lists^foldl/2-0-"/3
        (mix) lib/mix/compilers/elixir.ex:555: Mix.Compilers.Elixir.write_manifest/5
        (mix) lib/mix/compilers/elixir.ex:198: Mix.Compilers.Elixir.compile_manifest/9
        (mix) lib/mix/task.ex:316: Mix.Task.run_task/3
        (mix) lib/mix/tasks/compile.all.ex:68: Mix.Tasks.Compile.All.run_compiler/2
        (mix) lib/mix/tasks/compile.all.ex:52: Mix.Tasks.Compile.All.do_compile/4

Why does it need to compile more code? The fact that all the modules that are being redefined have the word view in their name suggests to me that this has something to do with templates.

Is there a way to compile this extra code before running the application? Or have it recompile without trying to write to the filesystem?

I am using Phoenix 1.3.4, because there are no SQLite adapters for Ecto 3 at the moment.

I don’t do much work with Phoenix, but i know it is possible to deploy Elixir/Phoenix apps to a RO filesystem. That is how we deploy Nerves devices. We compile and build the release on a regular development machine and deploy the erlang release (which can in itself include erts removing the need to install erlang on your production machine)

The issue is that it looks like it’s being launched via mix instead of a release. mix is designed for development purposes, so it will often recompile a lot of things on every launch, especially as it dynamically loads modules.

Releases on the other hand don’t, they are static, and if build_embedded is on then all modules get statically loaded regardless (no hickups on first-loading of modules), etc… You always want to use a release.


You use Distillery for that, right? I’ll try that.

1 Like

Using Distillery I have been able to get my application to start.

Right now I am stuck on getting migrations to run, though. I have tried following the instructions from the documentation, but my database does not get migrated when I run bin/historian migrate. There are no errors, just this output to the log:

Starting dependencies..
Starting repos..
1 Like

Check you’ve changed the :my_app to your actual app name where @repos is defined in the example code.


That was indeed the problem.

1 Like