Setting up Postgres database for Elixir/Phoenix

Hello, we are setting up a Elixir/Phoenix project on Windows (required by the client). We cloned the project from our github repo and trying to run it on windows but we are stuck at creating a postgres user.

Using cmd, we are able to execute initdb -D app_db but when its time to start the db server, with pg_ctl start -D app_db command, we were faced with this error messages.

We run as administrator on cmd and had set the postgres path already but the error persist.

I know this might not be the perfect forum to ask this question as others might think it is a problem related to postgres and not exactly about Elixir/Phoenix but we have already tried every possible solution we could find in the internet and i was thinking that other developers here used to solved this error on a windows machine.

Any idea or suggestion would be very much appreciated by us :pray::heart:

Did you try this?

1 Like

Also take a look at Windows Firewall and a few other pieces.

The following post might be helpful.

1 Like

Thank you for these links sir :heart:, we’ll try all of these suggestions later :pray:

The Postgres novice mailing list is also good at responding to these types of questions PostgreSQL: PostgreSQL Mailing List Archives

1 Like


Though we read the suggested solutions on the links given, we decided first to try some approaches that we again found on the internet like

net start postgresql-x64-15
net stop postgresql-x64-15

pg_ctl.exe start -D app_db

And other combinations of these but none works. Along the way we thought of just open postgres console with psql postges; and it throws an error. With did tried some more combinations like psql -U postgres, etc. but keep throwing errors.

Then we pause a little and was now decided to do just what the suggestions given by those links but my buddy tried for one more time psql start -D app_db and suddenly it worked and the server started!. :flushed:

I don’t know how it happens now…