Socket disconnecting after 60 sec without sending data

Hi,
My socket are disconnected every 60 sec when they’re not sending data.
I tried to change the idle_timeout to :infinity: (debugging purpose) but nothing changes :confused:

Here is my config:

Capture d’écran 2021-05-19 à 10.38.10

Someone has an idea ?
Thx

I’m using cowboy handler for my websocket. (cowboy 2.9)

My understanding most browsers and proxies will close the socket if there is no data after a while. You need to send a ping or similar over the wire if you want to keep it open.

2 Likes

I have a ping mechanism : server is sending ping message. But it’s when the client doesn’t send data for 60sec that there is a disconnection.

Capture d’écran 2021-05-19 à 10.57.40

I don’t use proxy for this. But i’ll check if it’s the browser which close the connection.

Are you using something different than Phoenix’s channels? The official JS client by default sends a heartbeat every 30 seconds which keeps the connection alive. Otherwise, as José mentioned, proxies and browsers will kill the connection.

We recently had a nasty timing issue where a channel would “randomly” die. The issue was that one of the proxies presumably had a 30 second timeout, so the issue would only be reproducible in the prod environment when the heartbeat would be just a few milliseconds too late :grimacing:

3 Likes

Yes, I need something low level , that’s why i’m not using Phoenix Channels but cowboy socket :wink:
And I’m using Action cable js (My purpose is to make my server in elixir compatible with Action cable js).
But this client doesn’t send heartbeat :confused: (Client just receive heartbeat from server), otherwise the connection won’t be closed. With Cowboy socket, there is a idle_timeout which close the connection if the client doesn’t send data for 60sec, but this option is set to infinity in my case. That’s why i’m not understanding my issue.

I see, thx for sharing this experience. I’ll be careful at proxies :wink: But in my case client and server are in local and there is no proxies between them.

Have you checked that you are really receiving a pong from your clients? I am not sure about cowboy’s handler callbacks. But Phoenix.Socket.Transport implements a handle_control callback which allows you to check if a pong is received. And as it is based on cowboy, you should have something similar.

Ping / pong needs to be implemented on both sides. I know about Firefox automatically responding to pings. But maybe your library does not work that way. I guess this would cause a 60s timeout, as no messages are received.

What you did set an “infinite” or no timeout value for regular HTTP requests. But you wanted to change the default timeout for websocket connections, which is different to configure. You may need something like

socket "/cable", ServerWeb.YourSocket,
  websocket: [      # <- add this!
    timeout: 3000. # <- add this!
  ],
  longpoll: false

This option is documented here. As far I undertand it still maps to the low-lewel cowboy idle_timeout option that default to 60s, but here you’re controlling the timeout in the websocket connections rather than the HTTP requests.