Sublime SuperElixir Package Problems

I installed SuperElixir Package on Sublime Text 3 and followed the instructions (installed SublimeLinter
and Elixir also) in order to lint my Elixir projects.

However, I think Sublime can’t find the linter. I only get the message <file>: No lint results.
As for the Elixir package for syntax highlight and formatting, I added "mix_format_on_save": true to the settings, but it isn’t working. Only through the super+shift+c keybinding.

Has anyone had these problems also?
Thanks in advance!

I skimmed the packages source code.

  • It ships with a very old version of elixir_sense, it might simply not work with current elixir versions.
  • “Linting” seems to only inlcude compiler warnings. Try to_charlist vs. to_char_list, the latter should trigger a compiler warning.
  • I can not say anything about the format on save thing. I found that that the setting is mentioned in the “Elixir” plugin, though I can’t say much beyond that.

Instead of the very old “SuperElixir”, have you considered using LSP + elixir-ls (config example). You should probably use a tagged version of the elixir-ls, master likes to break every now and then :smiley:

1 Like

Thank you! I tried LSP + elixir-ls and it works great! Even on save format started working properly, don’t really understand why.

I got one last question due to elixir-ls dialyzer integration. Since there isn’t an official plugin for Sublime, how do I enable/disable dialyzer here? Setting elixirLS.dialyzerEnabled to false in LSP client settings doesn’t work.


1 Like

I can’t tell for sure, but I assume, you need to set it in initializationOptions.

  "elixir-ls": {
    "initializationOptions": {
      "elixirLS": {
        "dialyzerEnabled": false
    // existing settings

Sorry, still doesn’t work. I’ll keep it as it is, and if I find a solution I’ll post it here!

Thanks for the tips!