Trying to build a CLI with relative references to 2 OTP apps

I am trying to build an application that should be something like a self-launching microservice. You pass a few parameters to the CLI, and then it starts the OTP app containing the business logic and also starts the Phoenix OTP app that provides the RESTful API routes. So I’ve got 3 directories (not an umbrella): host_api, host_core, and cli.

The CLI includes a path reference to both host and core. When I run the CLI, I get the following error message:

11:47:44.829 [warn]  no configuration found for otp_app :host_api and module HostApiWeb.Endpoint

How do I supply configuration to get rid of this warning? Is there something that I’m doing wrong, setting up incorrectly?

I tried using an umbrella project but that flat-out prevents me from running the task.

Right after I run the first, the second attempt to run this produces:

 mix escript.compile
** (Mix) The task "escript.compile" could not be found. Did you mean "escript"?

I have to remove the _build directory to get rid of that message. Then, every attempt after that to escript compile files. No matter what directories I delete, it doesn’t recognize that task.

Please disregard. It looks like I’ve just been trying to use Elixir in a way it wasn’t intended.