Turn off or delay timex tzdata log messages

I am using timex for date maths and I notice that there are always debug messages when my app starts.

I want to make my app wait until the tzdata has loaded. I see the Tzdata.ReleaseUpdater uses Process.send_after(self(), :check_if_time_to_update, 3000) to do the things that send this debug log (I hope I have located that correctly).

Is it possible to have my app startup wait until tzdata has loaded? Application.ensure_loaded(:tzdata) did not work.

If that is not possible, maybe it is possible to turn off the log messages only for that package. Is that possible? Have other people had this problem? How to solve?

Thank you!

You can either have a genserver (blocking in init) which periodically polls some state in tzdata which allows it to check if the update is complete, or ignore debug level logs. The former might be problematic if genserver blocks for too long so that its supervisor fails.

First approach (might make the app fail to start and I haven’t actually tried it out):

defmodule TzdataWaiter do
  use GenServer

  def start_link(_opts) do
    GenServer.start_link(__MODULE__, [], name: __MODULE__)

  def init(_opts) do


  defp wait_for_tzdata do
    case Tzdata.zone_list() do
      [] ->
      [_|_] -> 

Second approach (if you just want to make the logs go away):

# if in iex
iex> Logger.configure(level: :info)

# if in config
config :logger, level: :info

Or you can completely purge the debug logs from Tzdata.ReleaseUpdater since it’s using Logger.debug macros (it wouldn’t have worked if it used Logger.log or :logger):

config :logger, 
  compile_time_purge_matching: [
    [module: Tzdata.ReleaseUpdater, level_lower_than: :info]

Are you referring to messages like this?

00:23:37.324 [debug] Tzdata polling for update.

00:23:37.611 [info]  tzdata release in place is from a file last modified Tue, 22 Dec 2020 23:35:21 GMT. Release file on server was last modified Sun, 24 Jan 2021 19:35:23 GMT.

If so these messages can be disabled. If you’re running Elixir 1.9 or greater you need to create a config directory with a config.exs file at the root level. Inside the config.exs file add these lines.

use Mix.Config
config :tzdata, :autoupdate, :disabled

Not sure if this is what you’re looking for but this will turn off the debug messages you see when your app starts.

Check out the tzdata lib for more configuration info.

This will also turn off the tzdata autoupdate mechanism, not just the debug messages.

Yep, you’re right. Is there a way to keep the autoupdate and disable the messages?

The first response by @ruslandoga lists several options, I think the first and last one look promising.


Thank you for the good ideas!

I tried putting Tzdata.ReleaseUpdater.check_if_time_to_update() at the top of my application start. This works for me because I can see that the tz has updated and these log messages appear before any log messages that my app sends.

I also tried Logger.put_module_level/2 and that seemed to work but then I worried that maybe I need to see logs sometimes.

1 Like

I keep running into the error when deploying a release on render.com. Any ideas on how to take care of this?

* (ArgumentError) errors were found at the given arguments:
Dec 5 10:30:29 PM  
Dec 5 10:30:29 PM    * 1st argument: the table identifier does not refer to an existing ETS table
Dec 5 10:30:29 PM  
Dec 5 10:30:29 PM      (stdlib 3.15.2) :ets.lookup(:tzdata_current_release, :release_version)
Dec 5 10:30:29 PM      lib/tzdata/release_reader.ex:74: Tzdata.ReleaseReader.current_release_from_table/0
Dec 5 10:30:29 PM      lib/tzdata/release_reader.ex:17: Tzdata.ReleaseReader.simple_lookup/1
Dec 5 10:30:29 PM      lib/tzdata/release_reader.ex:9: Tzdata.ReleaseReader.zone_and_link_list/0
Dec 5 10:30:29 PM      lib/tzdata.ex:61: Tzdata.zone_exists?/1
Dec 5 10:30:29 PM      lib/timezone/database.ex:36: Timex.Timezone.Database.time_zone_periods_from_wall_datetime/2
Dec 5 10:30:29 PM      (elixir 1.12.2) lib/calendar/datetime.ex:623: DateTime.shift_zone_for_iso_days_utc/5
Dec 5 10:30:29 PM      (elixir 1.12.2) lib/calendar/datetime.ex:1384: DateTime.add/4