Umbrella, Phoenix, Distillery project configuration

Hello there!
I have a big struggle with properly setting up a project for running (and deploying with docker, afterward).

The structure of the umbrella project is the following:

A = Phoenix no-ecto, no-html app
B = Database “handler” using the library for connectig to NoSQL DB app
C = Controller app which is using some functionality of Phoenix, but itself is not a phoenix app

app A has in deps app C
app C has in deps app B

Physically all the deps I need are sitting in the root folder and then in every app I set the path to …/…/folder and so i “pull” only deps I need for a particular app. This is ok, its working fine.

When I start in the root folder mix phx.server it starts my app A and everything worked just fine. BUT when I tried to create a release using distillery I am not able to run the build with this error Protocol 'inet_tcp': the name myApp@ seems to be in use by another Erlang node.

I thought it is because distillery release is trying to run all the apps which are included in it. So I followed this workaround (title How do I run multiple instances of a release on the same host?). But it didn’t work either.
So my question is (based on project structure req.) there any way how to configure this project structure in a better way, and/or just need to modify/add some configuration in umbrella/distillery/Phoenix :smiley:

Thanks in advance !!

1 Like