Unable to reload templates

Templates don’t reload…even after restarting the server…any hints please

@elixirnewbie mb, pages, generated from templates by views? Anyway, the first hint: provide more details please (if you want to receive other hint).

@madeinussr I have tried everything…installed inotify…restarted the server

@elixirnewbie, you’ve described your approaches to resolve the problem, but didn’t provide any details: what are templates, how your views/controller action look like, etc. It’s really hard to help with such lack of information (well, at least for me).

@madeinussr I have a controller PageController which renders to a Page view and then to “entry.html.eex”

Have you tried calling the template from IEX?

MyServer.PageView.render("entry.html.eex", %{your: assigns}) # I think this is the syntax...

@OvermindDL1 just tried calling the template from iex …still get a different string to what it’s supposed to be…

here’s my entry.html.eex


that “content” is inside the div tag

@elixirnewbie and what you’ve got instead?

1 Like

@madeinussr before “content” it was “fan”

And have you done a mix clean && mix compile as well?

1 Like

@OvermindDL1 I have tried everything…nothing works

Well if the source code is not matching the output then that means that either the wrong module or information is being called by your code somewhere or there is a compiled file containing the old data (which a clean would clear out). :slight_smile:

1 Like

If direct call of a View’s function with valid params returns unexpected result, it’s not browser cache or something too. Agree with @OvermindDL1: it’s either wrong view or wrong params. I though about compiled files too, but as @elixirnewbie said, he did recompilation. I’m intrigued.

1 Like