Unable to start a phoenix app created with release (Elixir 1.9.0-rc.0)

Hello I installed elixir 1.9.0-rc.0 using asdf
I updated hex using mix local.hex

After that I created a phoenix app using mix phx.new test_rel --no-webpack
Changed the db config and started the app using mix phx.server
App runs fine on port 4000

After that I created a release mix release
It created a release under _build/dev/rel/test_rel/bin/test_rel

I am able to run the app in iex mode using
It created a release under _build/dev/rel/test_rel/bin/test_rel start_iex

but when I do
It created a release under _build/dev/rel/test_rel/bin/test_rel start
Noting happens. My phoenix app doesn’t start and I get no output.

Am I missing some steps? Please help.

Testing this on Mac OS Mojave and also on Ubuntu 18.04 digital ocean box. Same result.


That solved it. Thank you so much.

Can you please explain what fixed it … from your original query you are building a DEV release which will pull in your dev.exs config file. Which I assume has your local variables set.

I have upgraded elixir to 1.9 and built a release to run locally:

MIX_ENV=dev mix release

It creates the directories as expected but the command

_build/dev/rel/app/bin/app start

Just hangs … no output.

Any help will be appreciated.



I worked it out … it was because one of the config settings was failing. I found this great post


And started using System.fetch_env! so that it will throw. After that was able to resolve config files.



Glad it worked out for you.
For me it was
config :app_name, AppName.Endpoint server: true