Unzip .zip file to a folder using :zip module

I’m trying to unzip a .zip file to a specific folder path:


:zip.unzip(zip_path, {cwd: "/tmp/test-extracted/"})

** (SyntaxError) test.exs:18: syntax error before: cwd
    (elixir) lib/code.ex:677: Code.require_file/2

Please how can i extract to a specified folder?

First, "/tmp/test-extracted" is a binary and Erlang mostly expects charlists. So binaries/strings will need to be converted to charlists first.

cwd = "/tmp/test-extracted/"
cwd = to_charlist(cwd)

Charlists can be represented by surrounding the string part with single quotes: 'charlist'. That can be easy to forget, so it’s better to use the sigil and do something like this: ~c'charlist'.

Second, Erlang opts are usually represented like this: [{:someopt, true}, :someotheropt, {:somethingelse, ~c'thing'}].

I haven’t tested, but this should be pretty close to the correct form:

:zip.unzip(zip_path, [{:cwd, ~c'/tmp/test-extracted/'}]) # also represented by [cwd: ~c'...']
1 Like

Thanks immensely @voughtdq for this clear explanation.

I have tried it as mentioned but i got bad match error

case :zip.unzip(~c'priv/static/files/document.zip', [{:cwd, ~c'/tmp/test-extracted/'}]) do
      {:ok, content} ->
        IO.inspect content
      {:error, error} ->

The logged output is

    {:zip, :get_unzip_opt,
       {:cwd, '/tmp/test-extracted/'},
       {:unzip_opts, #Function<21.81481102/2 in :zip.get_unzip_options/2>,
        #Function<26.81481102/2 in :zip.get_input/1>,
        #Function<22.81481102/1 in :zip.get_unzip_options/2>, [:raw],
        #Function<23.81481102/1 in :zip.get_unzip_options/2>, []}
     ], [file: 'zip.erl', line: 538]},
    {:zip, :do_unzip, 2, [file: 'zip.erl', line: 364]},
    {:zip, :unzip, 2, [file: 'zip.erl', line: 358]},
    {RecordBank.Modules.Import, :unzip, 0,
     [file: 'lib/record_bank/modules/import.ex', line: 5]},
    {:erl_eval, :do_apply, 6, [file: 'erl_eval.erl', line: 670]},
    {:elixir, :eval_forms, 4, [file: 'src/elixir.erl', line: 233]},
    {IEx.Evaluator, :handle_eval, 5, [file: 'lib/iex/evaluator.ex', line: 250]},
    {IEx.Evaluator, :do_eval, 3, [file: 'lib/iex/evaluator.ex', line: 230]},
    {IEx.Evaluator, :eval, 3, [file: 'lib/iex/evaluator.ex', line: 208]},
    {IEx.Evaluator, :loop, 1, [file: 'lib/iex/evaluator.ex', line: 94]},
    {IEx.Evaluator, :init, 4, [file: 'lib/iex/evaluator.ex', line: 24]},
    {:proc_lib, :init_p_do_apply, 3, [file: 'proc_lib.erl', line: 247]}

Please what could be wrong?

Similar code works for me:

iex(1)> :zip.unzip('zshrc.zip', [{:cwd, '~/tmp'}])
{:ok, ['~/tmp/.zshrc']}

Could you therefore please provie more information about your system, as which operating system you use, which OTP version, what tool originally created that zip file, etc.

Thanks immensely @NobbZ.

I’m on macOS High Sierra (10.13.4)

Erlang/OTP 20 [erts-9.3.1] [source] [64-bit] [smp:4:4] [ds:4:4:10] [async-threads:10] [hipe] [kernel-poll:false] [dtrace]

The zip was downloaded from linkedin following the attachment below

@NobbZ I forgot to also mention that the implementation is inside a Phoenix 1.3 application

@NobbZ and @voughtdq thanks immensely for your contributions.

It’s now working! The problem was with the initial trailing slash. I removed the trailing slash preceding the directory name as below and it worked.

case :zip.unzip(~c'priv/static/files/document.zip', [{:cwd, ~c'tmp/test-extracted/'}]) do
      {:ok, content} ->
        IO.inspect content
      {:error, error} ->

That means you are now putting it in a tmp directory relative to cwd rather than in the root /tmp directory, is that intended?

Thanks immensely @OvermindDL1.

The actual folder structure is a phoenix app 1.3 structure + uploads folder.

My original intension is to extract the zip inside the uploads folder.

Without cwd option, it extracts the zip content directly in the app root folder which is not what i want.

Thanks so much.

1 Like

Cool, thought so. :slight_smile:

1 Like