Upgrading to elixir 1.14 & OTP 24.x

Posting here just for anybody that runs into this

I had a phoenix app deployed on gigalixir from a while back and had issues upgrading my elixir version. Two errors:

  1. OTP 24.x didn’t work because Sorry, Erlang 24.3.3 isn't supported yet. For a list of supported versions, please see https://github.com/HashNuke/heroku-buildpack-elixir#version-support
  2. Updating stack from gigalixir-18 to gigalixir-20 didn’t work because
web.1  | /app/erts-11.2.1/bin/beam.smp: error while loading shared libraries: libtinfo.so.5: cannot open shared object file: No such file or directory
 web.1  | exited with code 127
 system | sending SIGTERM to all processes

Previously I thought I should do one or the other. After seeing this post today I finally tried both and it worked. Started with step 2, and the app did not deploy. But then I committed the updated elixir_buildpack.config file (leaving stack as gigalixir-20)


Not sure if my typical git push gigalixir master would have worked but my success was with git -c http.extraheader="GIGALIXIR-CLEAN: true" push gigalixir

1 Like