Using Map.merge in a select statement

I’m trying to clean up my code by extracting default values in a select statment. I would like to do the following:

defaults = %{ x: :nil }  # Large in reality, reused in different queries
from(product in Products, select: Map.merge(defaults, %{ y: true })

However, Ecto can’t compile the statement. Any tips on how to deal with this situation?

Can you elaborate on what you want?
defaults will be a set of static values that will be added to the query in case they’re not present in the query result?

if that’s the case you can’t do that in a query the way you want. either you do that with cte(or case conditions inside the select statment) or you handle that in the application side after you retrieve the query data:

from(..., select: %{...})
|> Repo.all()
|>, &1))

This problem arose in the context of several queries that get UNIONed, it’s not the exact same result set that is present. So doing things application side is not an option.

Why not? data present after the Repo.all is not required to be uniform for the application side to work.
with Map.merge/2 the second map(in my example the results of the query) will always have precedence over the default value.

If you need the defaults data to make the union possible, you gonna need to be explicit setting those values in the query.

Would select_merge/3 work?

1 Like

Ecto queries are a DSL to build sql queries, which you can see when doing e.g. Repo.to_sql(:all, query). It therefore cannot allow you do run any actual elixir functions – the db wouldn’t know what to do with them. select specifically goes a bit astray from the plain sql in that it allows you to supply a non tabular format for data, which the data returned from the db is then mapped into. That still doesn’t allow you to use elixir functions though. For arbitrary transformations map the data manually after having loaded it from the db.


@cevado to clarify: I should have written that it’s not the exact same column set that is present.