VScode mix.exs error - Could not compile with "make"

Background

I have an umbrella app where I am making a build for windows using bakeware:

I have followed the normal setup for windows:

choco install -y zstandard make mingw

I have installed elixir and erlang otp via their official website installers:

Problem

I am able to run and do everything normally, but my VSCode marks my mix.exs file as a huge red error blob:

an exception was raised:
    ** (Mix.Error) Could not compile with "make" (exit status: 2).

        (mix 1.13.1) lib/mix.ex:515: Mix.raise/2
        (elixir_make 0.6.3) lib/mix/tasks/compile.make.ex:154: Mix.Tasks.Compile.ElixirMake.run/1
        (mix 1.13.1) lib/mix/task.ex:397: anonymous fn/3 in Mix.Task.run_task/3
        (mix 1.13.1) lib/mix/tasks/compile.all.ex:92: Mix.Tasks.Compile.All.run_compiler/2
        (mix 1.13.1) lib/mix/tasks/compile.all.ex:72: Mix.Tasks.Compile.All.compile/4
        (mix 1.13.1) lib/mix/tasks/compile.all.ex:59: Mix.Tasks.Compile.All.with_logger_app/2
        (mix 1.13.1) lib/mix/tasks/compile.all.ex:36: Mix.Tasks.Compile.All.run/1
        (mix 1.13.1) lib/mix/task.ex:397: anonymous fn/3 in Mix.Task.run_task/3ElixirLS

Question

In Bakeware’s page there is a section:

Change the default MAKE environment variable used by elixir_make from nmake to make (set it permanently to get rid of the errors in VSCode)

  • But how do I do this?
  • Is something wrong with my VSCode setup?

What extension are you using? You’ve tagged vscode-elixir which is not maintained and hasn’t been updated since 2017. If you use ElixirLS then you can set arbitrary environment variables if you’re using the latest version. Here’s the PR that exposed it in the VSCode extension add setting for environment variables by vacarsu · Pull Request #213 · elixir-lsp/vscode-elixir-ls · GitHub

1 Like

@axelson My bad, you are correct I am using ElixirLS.
In order to try and fix it I have read this file on how to have a proper mix.exs file setup for make:
https://hexdocs.pm/elixir_make/Mix.Tasks.Compile.ElixirMake.html

And I ended up with the following:

defmodule MarketManager.MixProject do
  use Mix.Project

  def project, do:
    [
      apps_path: "apps",
      version: "0.1.0",
      make_executable: "make",
      start_permanent: Mix.env() == :prod,
      deps: deps(),
      releases: releases()
    ]

  defp deps, do:
    [
      {:bakeware, "~> 0.2.2"}
    ]


  defp releases, do:
    [
      desktop: [
        steps: [:assemble, &Bakeware.assemble/1],
        applications: [
          web_interface: :permanent,
          runtime_tools: :permanent
        ],
        include_executables_for: [:windows]
      ]
    ]

end

I have also set a Windows System Env Var:

MAKE: C:\ProgramData\chocolatey\bin\make.exe

I have also searched in ElixirLs’s settings page in VSCode and I was not able to find anything that would allow me to take advantage of the new PR (aka, no section called “define env vars”). I am sure I missed it:

Aside from a couple settings on the top regarding dialyzer, I found nothing.

The error still persists (albeit in a different form), I am not sure why…

    ** (Mix.Error) Could not compile with "C:\ProgramData\chocolatey\bin\make.exe" (exit status: 2).

        (mix 1.13.1) lib/mix.ex:515: Mix.raise/2
        (elixir_make 0.6.3) lib/mix/tasks/compile.make.ex:154: Mix.Tasks.Compile.ElixirMake.run/1
        (mix 1.13.1) lib/mix/task.ex:397: anonymous fn/3 in Mix.Task.run_task/3
        (mix 1.13.1) lib/mix/tasks/compile.all.ex:92: Mix.Tasks.Compile.All.run_compiler/2
        (mix 1.13.1) lib/mix/tasks/compile.all.ex:72: Mix.Tasks.Compile.All.compile/4
        (mix 1.13.1) lib/mix/tasks/compile.all.ex:59: Mix.Tasks.Compile.All.with_logger_app/2
        (mix 1.13.1) lib/mix/tasks/compile.all.ex:36: Mix.Tasks.Compile.All.run/1
        (mix 1.13.1) lib/mix/task.ex:397: anonymous fn/3 in Mix.Task.run_task/3ElixirLS```

I was able to somehow fix the issue.
Bakeware, the dependency, really likes Powershell. But not any powershell. A powershell with admin rights.
To get rid of the warning one must perform the following steps while VSCode is closed:

  1. Open Windows Powershell in admin mode
  2. set $env:CC="gcc"
  3. set $env:MAKE="make"
  4. set MIX_ENV to something. It doesnt have to be prod, but since powershell does not set this value by default, you have to manually set it yourself. Before running tests, fetching dependencies or anything.
  5. mix deps.get

After this, if you still get the red wall of death, trying deleting your .elixir_ls folder to force to go again.
Then open VSCode with code .

Hope it works for you, it did for me.
Trying this with any other terminal will result in seeing the red wall of death. According to my experiments, powershell is the only that works.

In my experience, you don’t need to use PowerShell, nor do you require it to be an administrative shell. You do however need to set those environment variables, which I’m sure I added to the readme. Setting MAKE with the $env command won’t last, so do it through the Windows UI (press Windows key and type ‘env’ and the shortcurt should show up) to keep VSCode happy.

Fun fact, you can also use zig as your c compiler with CC=zig cc.

1 Like