Where should I set REPLACE_OS_VARS for it to work with distillery vm.args?

Hi all you lovely people.

I’m trying to setup multi-node deployment for an application. But I can’t seem to make REPLACE_OS_VARS work. I’m using distillery, and I want to set the -name arg in the vm.args file. It is all setup as according to the docs, but the REPLACE_OS_VARS env variable is not doing anything. I’ve tried setting it in /env/environment, ~/.bashrc & ~/.profile on the environment where the app is running. But it doesn’t do anything it seems. The ${ENV_VAR} placeholders in the vm.args file are not being replaced.

Does anybody have a clue why that is? What am I missing?

1 Like

So it seems to be working correctly. The error I was facing was, that I was setting cookie in the /rel/config using set(cookie: "${ERL_NODE_COOKIE}" and I thought that would set the ${COOKIE} variable in the vm.args file. It did not. Using ${ERL_NODE_COOKIE} in the vm.args file solved this