WiFi problems with Nerves Livebook on Raspberry Pi Zero 2W

Hello everyone! I am new to Nerves, so I tried to do the recommended thing and just start with Livebook. I got myself a Raspberry Pi Zero 2W, downloaded the .fw file for Raspberry Pi 3a and flashed it on my SD card by using the command

sudo NERVES_WIFI_SSID='2.4GHz network name' \
NERVES_WIFI_PASSPHRASE='2.4GHz network password' \
fwup ./nerves_livebook_rpi3a.fw

Plugged the USB power in, the diode started blinking… and blinking… and blinking… and blinking… Parallely I tried to connect to nerves.local… and try to connect… and try to connect… and try to connect… So what am I missing guys?

P.S.: This might turn out to be some sort of an issue between the R-Pi and the WiFi. However, I cannot test this, due to lack of SSH connection. If you have some sort of ideas on this front, I would be happy to hear them as well.

I don’t have an answer as I never played with Nerves but I would suggest if you had another Raspberry Pi from a different model to try it and see if you get the same problems or not. I believe you would learn by comparing the process and results.

There is some debugging going on in an already closed issue regarding boot and wifi problems with the Pi Zero 2W.

Maybe this is a good starting point.
I remember I also had issues with wifi with a Pi3 the other day but I just plugged in a cable and didn’t debug it any further.

I tried this just now with my R Pi Zero 2 W, but I’m also able to connect via USB, to make the initial connection. When I look at the VintageNet.info, it doesn’t show the WiFi configuration passed from the env variables.

Interface wlan0
  Type: VintageNetWiFi
  Present: true
  State: :configured (0:15:37)
  Connection: :disconnected (0:15:38)
  MAC Address: "xx:xx:xx:xx:xx:xx"
      type: VintageNetWiFi,
      vintage_net_wifi: %{networks: []},
      ipv4: %{method: :disabled}

I’m doing this from Windows, but as far as I know, the following should be equivalent:

set NERVES_WIFI_SSID='my_ssid' & set NERVES_WIFI_PASSPHRASE='my_passphrase' & fwup nerves_livebook_rpi3a.fw

Since I can connect via usb0, I’m able to subsequently add the VintageNet configuration on the running device:

iex> VintageNetWiFi.quick_configure("my_access_point", "secret_passphrase")

and WiFi appears to work once that is done.

I don’t know if this is helpful or not, but it does show that WiFi can be set up with the nerves_livebook firmware on the R Pi Zero 2 W.