Win Installer Fails On Non-C: Drive

This Windows intaller requires installation on C: drive.

When i attempted to install, with Erlang and C++, on D: drive, i got errors in the command window, near the end of the install process, saying something like:

“error: cannot find C: drive”

Consider this a request to allow non-C: installation.

Thx!

For me this sounds like a serious problem which needs to get properly reported.

Can you provide a bug report at its repository?

Please provide some more information there, like screenshots and a complete description of your workflow.

done. Provided all i could.

https://github.com/elixir-lang/elixir-windows-setup/issues/10

i also posted this issue
thx!

On attempting re-install, i accepted C: drive default.

I still got the same error.

i updated the github issue.

Heh, I remember back when I ran windows at home (XP was still ‘the new thing’, also ran linux as well) I had a C drive that was dedicated to the OS (I reinstalled often) and everything else was installed elsewhere. As in nothing that was not the SYSTEM user could even touch the C: drive. A lot of installers were very crapily made that they just puked when you tried to install them when, as far as they could see, C: did not even exist (The other drives had a %WINDIR% that pointed to it in a way that they could see the windows files and libraries). ^.^;

No issue with Windows 10 Pro Version 1703 OS Build 15063.540. Successfully installed and run

  • Erlang at D:\Program Files\erl20
  • Elixir at D:\Program Files\elixir\1.5.1

Steps:

  • Installed OTP 20.0 Windows 64-bit Binary File from https://www.erlang.org/downloads to D:\Program Files\erl20 (D:\Program Files\erl9.0 was the default probably should have just left it).

  • Added D:\Program Files\erl20\bin to the Path under User variables to make sure that any process could pick it up (see here).

  • Verified that Erlang worked in a new command prompt.

    C:\Users\name>erl
    Eshell V9.0 (abort with ^G)
    1> io:fwrite(“Hello world!~n”, []).
    Hello world!
    ok
    2> q().
    ok
    3>
    C:\Users\name>

  • Created a new ex-setup folder under Documents (a user folder that was moved to D: after creation of the user profile that itself still resides on C:). Moved the elixir-websetup.exe from the downloads folder into ex-setup. Double-clicked it to start the download. Selected version 1.5.1 and checked “Defer installation (advanced)” which created elixir-v.1.5.1-setup.exe.

  • Double-clicked elixir-v.1.5.1-setup.exe to start the installation. Confirmed the Erlang installation location. Customized the install location to D:\Program Files\elixir\1.5.1. Opted to let the installer add the file paths to the system variables (so I could remove the one I added manually for Erlang).

  • Verified installation in a new command prompt

    C:\Users\name> iex
    Interactive Elixir (1.5.1) - press Ctrl+C to exit (type h() ENTER for help)
    iex(1)> IO.puts “Hello World”
    Hello World
    :ok
    iex(2)> Terminate batch job (Y/N)? y
    C:/Users/name>

FYI: that error can simply be the result of creeping system instability.

With Microsoft systems lots of stuff that is possible isn’t necessarily considered safe. For the longest time, moving anything but the visible folders under a user (Documents, Music, Pictures, Videos) was considered an unsupported configuration by Microsoft (however aggravating that may have been).

… absence hasn’t made my heart grow fonder of Windows in the least.

1 Like

i found the issue, it’s not OS instability. The cause is:

i keep Win Updater and BITS services disabled by choice, since updates for Win 8 very rare these days, and those 2 services consume a lot of resources when they’re running.

Enabling those 2 services made the installer work to C: drive. Did not try D:.

cheers!