Windows 10 install failing with missing tmp output file - Elixir 1.4.2

When I’m trying to install Elixir 1.4.2 on a brand new Windows 10 Pro install, I’m getting the following error:

Unable to execute file:
C:\Users\[username]\AppData\Local\Temp\is-2MKN5.tmp\Output\elixir-v.1.4.2-setup.exe

CreateProcess failed; code 2.
The system cannot find the file specified.

This happens right after installing Erlang 19 and then proceeding to install Elixir, with the Elixir web installer.

Any ideas of how to fix this?

I’ve tried before and it has worked, but I’m moving a new machine with a fresh install and its failing with this error.

2 Likes

Sounds like it was not able to download it. You using a proxy, firewall blocking it, etc… etc…?

2 Likes

No proxy, and I’ve already allowed the firewall to go through.

I just found an old thread that mentions something similar https://groups.google.com/forum/#!topic/elixir-lang-talk/N41EQNXkxO0

But, i think the problem there was it was related to Powershell or something, but the script doesn’t seem to be using Powershell but windows cmd.

1 Like

Ok, no idea what happened, but it works now.

I tried completely disabling my firewall and it didn’t work.

But then after I re-enabled my firewall and just made the exception when the setup launched, it worked!

Weird…

Thanks for the help.

1 Like

Lol, that is Windows for you. I use Windows 10 at work and the amount of Weird that happens is astounding… ^.^

2 Likes

I’m sorry I couldn’t resist :wink:

There is really weird things going on sometimes with Windows, I can have uptime of weeks sometimes, and then suddenly out of nowhere something just stops working, and I try to debug it to no avail. But simple computer restart just works :confused: So as silly as it may sound, thirst troubleshooting advice for windows: turn it off and on again :frowning:

3 Likes