Deploy failed(Unable to select a buildpack)

I’m using Gigalixir
But failed to deploy because of Unable to select a buildpack…
Local is working.
The following is the setting.What is wrong setting?

config.exs

use Mix.Config

# Configures the endpoint
config :gigalixir_plactice, GigalixirPlacticeWeb.Endpoint,
  url: [scheme: "https", host: System.get_env("APP_NAME") <> ".gigalixirapp.com", port: 443],
  secret_key_base: Map.fetch!(System.get_env(), "SECRET_KEY_BASE"),
  render_errors: [view: GigalixirPlacticeWeb.ErrorView, accepts: ~w(html json)],
  pubsub: [name: GigalixirPlactice.PubSub, adapter: Phoenix.PubSub.PG2]

# Configures Elixir's Logger
config :logger, :console,
  format: "$time $metadata[$level] $message\n",
  metadata: [:request_id]

# Use Jason for JSON parsing in Phoenix
config :phoenix, :json_library, Jason

# Import environment specific config. This must remain at the bottom
# of this file so it overrides the configuration defined above.
import_config "#{Mix.env()}.exs"

prod.exs

use Mix.Config

config :gigalixir_plactice, GigalixirPlacticeWeb.Endpoint,
  load_from_system_env: true,
  cache_static_manifest: "priv/static/cache_manifest.json",
  server: true,
  secret_key_base: Map.fetch!(System.get_env(), "SECRET_KEY_BASE"),
  url: [scheme: "https", host: System.get_env("APP_NAME") <> ".gigalixirapp.com", port: 443]

# Do not print debug messages in production
config :logger, level: :info

phoenix_static_buildpack.config

node_version=10.16.3
npm_version=6.9.0
yarn_version=1.19.1
phoenix_relative_path=.
assets_path=.

I tried to set clean_cache true and false, but probably no meaning.

elixir_buildpack.config

elixir_version=1.8.2
erlang_version=21.0

result

$ git push gigalixir master
Counting objects: 84, done.
Delta compression using up to 4 threads.
Compressing objects: 100% (84/84), done.
Writing objects: 100% (84/84), 8.04 KiB | 1.00 MiB/s, done.
Total 84 (delta 57), reused 0 (delta 0)
remote: Setting environment variables.
remote: * LIBCLUSTER_KUBERNETES_SELECTOR
remote: * LIBCLUSTER_KUBERNETES_NODE_BASENAME
remote: * APP_NAME
remote: * SECRET_KEY_BASE
remote: * PORT
remote: * SOURCE_VERSION
remote: Cloning into 'grateful-tender-bug'...
remote: done.
remote: Compiling code and generating slug.
remote: latest: Pulling from gigalixir-152404/herokuish
remote: Digest: sha256:01b2c78943f694bcb5e18d7305aa444fe8205007bd93c5b6ae4648a0c63a809a
remote: Status: Image is up to date for us.gcr.io/gigalixir-152404/herokuish:latest
remote: us.gcr.io/gigalixir-152404/herokuish:latest
-----> Unable to select a buildpack
remote: Command '[u'docker', u'run', u'--memory-reservation=512m', u'--rm', u'-e', u'GIGALIXIR_SHOULD_CLEAN_CACHE=False', u'-v', u'/tmp/tmpCAxajm/grateful-tender-bug:/tmp/app', u'-v', u'/tmp/gigalixir/cache/grateful-tender-bug/:/tmp/cache', u'-v', u'/tmp/tmpCAxajm/env:/tmp/env', u'--env=USER=www-data', u'us.gcr.io/gigalixir-152404/herokuish:latest']' returned non-zero exit status 1
To https://git.gigalixir.com/grateful-tender-bug.git
 ! [remote rejected] master -> master (pre-receive hook declined)
error: failed to push some refs to 'https//XXXXXXXXX:7f21c2cc-87a4-49eb-b3c1-f69f462c3deb@git.gigalixir.com/grateful-tender-bug.git'

Thank you as always.

Other things I tried

ssh pub key added to gigalixir
set env variable APP_NAME and SECRET_KEY_BASE

checked

1 Like

docker上で開発している場合docker内にもgitがインストールされてる必要がありますが入っていますでしょうか

返信ありがとうございます。
残念ながらDockerで開発していません、Localです。
Localのgit versionはgit version 2.17.0です。

I don’t use Docker.