Elixir Installer For Windows

Hi all,

I’m trying to use the Windows Installer for Elixir to install on Win 10. I run the installer and it gets to the point where it tries to download precompiled.zip and it fails. I have no doubt it’s a corporate firewall that’s blocking the download. What I was wondering is if anyone could suggest any way to workaround this? That is, download precompiled.zip manually and then point the installer at the downloaded location or something of that sort? It does seem to successfully download the OTP stuff–just balks on the precompiled.zip as far as I can tell.

FWIW,

image

image

Any suggestions would be greatly appreciated!

1 Like

Have run into this severally at client sites (both windows server and windows 10)

What I do is simply request that the machine/account be granted the required internet permissions.

You may even have further issues if you need to run mix.deps down the line

1 Like

Yeah I was afraid of that. I think the chance of getting them to unblock this is pretty slim. Thanks anyway Charles!

I’d suggest you install and use WSL2 so you have an actual Linux experience inside Windows. Then you could use asdf which is the widely accepted method of installing Erlang / Elixir.

Agree that WSL2 offers the best experience on Windows (assuming @Onor.io doesn’t need to do anything Windows-specific). But mightn’t that fall foul of the same firewall strictures?

There is a precompiled win32 install available for Elixir: Installing Elixir - The Elixir programming language. And the Windows builds of Erlang at Erlang Programming Language look like full compiled packages. I haven’t tried this though.

Ah, that’s not even a discussion. If you’re supposed to do programming but can’t download your development environment then you might as well escalate your IT ticket to the CTO and take a 6-month long paid vacation until they sort out their dysfunctional bureaucracy.

1 Like

Can you download from the links here GitHub - hexpm/bob: The Builder ?

Thanks for all the suggestions!

In fairness to my employers I am trying to convince them to look at Elixir. And blocking the download of .zip files containing binaries is just a security measure. I can, of course, ask them to make an exception; I was just trying to see if there were any way I could proceed without having to trouble the security folks. They’re, justifiably, reluctant to grant special exceptions.

Just now… :upside_down_face:

This is new project on a client site, it’s kinda hard to get clients to give “more than usual internet access”

Microsoft Windows [Version 6.3.9600]
(c) 2013 Microsoft Corporation. All rights reserved.

D:\Paperless\PeopleCost\server>mix deps.get
Could not find Hex, which is needed to build dependency :tzdata
Shall I install Hex? (if running non-interactively, use "mix local.hex --force") [Yn] y
** (Mix) httpc request failed with: {:failed_connect, [{:to_address, {'repo.hex.pm', 443}}, {:inet, [:inet], :etimedout}]}

Could not install Hex because Mix could not download metadata at https://repo.hex.pm/installs/hex-1.x.csv.

Alternatively, you can compile and install Hex directly with this command:

    mix archive.install github hexpm/hex branch latest


D:\Paperless\PeopleCost\server>mix archive.install github hexpm/hex branch latest
* Getting new package (https://github.com/hexpm/hex.git - origin/latest)
starting fsmonitor-daemon in 'C:/Users/!85010528/AppData/Local/Temp/mix-local-installer-fetcher-TvUxvA/deps/new package'
fatal: unable to access 'https://github.com/hexpm/hex.git/': Failed to connect to github.com port 443 after 21122 ms: Timed out
** (Mix) Command "git --git-dir=.git fetch --force --quiet --progress" failed

D:\Paperless\PeopleCost\server>

is hex down?

Looks like you couldn’t connect to GitHub?

can connect from the browser on the same server… strange.

also i’m using an elevated console

D:\Paperless\PeopleCost\server>mix local.hex --force
** (Mix) httpc request failed with: {:failed_connect, [{:to_address, {'repo.hex.pm', 443}}, {:inet, [:inet], :etimedout}]}

Could not install Hex because Mix could not download metadata at https://repo.hex.pm/installs/hex-1.x.csv.

Alternatively, you can compile and install Hex directly with this command:

    mix archive.install github hexpm/hex branch latest


D:\Paperless\PeopleCost\server>

Well I don’t know, man. I only had a problem with a corporate firewall once and I just went to the CTO and told them “look, I am here to do a job, please don’t put obstacles in front of me because I seriously don’t care about your company’s bureaucracy – now, can I do my job or not?”.

He was super confused that this pissed me off, tried to play it down and then put the blame on me (not sure how he imagined that will work), and I left on the spot.

They can play their little games without me. :man_shrugging:

Hope you solve your problem though!

Lucky you. When I had to do work on a customer’s site, I had to make damn sure that I fucking brought everything.

Ever since it happened to me once I’m very careful not to work with such customers.

For the right sum of money I’d consider the occasional exception but happily this principle of mine hasn’t been tested yet. :grimacing::laughing:

Maybe there needs to be a fully offline install mode for elixir… for very locked down environments

At one company I worked for years ago the devs ran our own VPN server at an external host to circumvent this kind of thing. I ran into one of the senior IT guys from that company later, who told me they knew about it, but made no fuss because they didn’t want too much scrutiny because they didn’t want knowledge of a porn server they ran for senior management to leak far. Seriously. I conceived a loathing then and there for the Australian business and tech world and tried to keep as far from it as I could consistent with surviving. It’s not quite as bad now from my few recent contacts with it.

2 Likes

Didn’t Elixir have .ZIP file distributions that you can unpack wherever? That way you can download one of those from your own machine, put it on a USB stick and use it on the internet-restricted machine.

Isn’t that what I linked to above? (ie. Installing Elixir - The Elixir programming language)

Yes, that’s why I’m not sure what’s stopping @CharlesO from using that (provided he downloads it from another machine and puts it on an external storage media).

I think the binary installs of Erlang from Erlang Programming Language are also complete & self-contained.