Elixir with ASDF: troubleshooting :observer.start

Hi. I recently switched computer and went from Ubuntu to OSX for Elixir. I installed Erlang/Elixir using asdf this time, but after installing I can’t start the observer in my iex session, didn’t have this problem before using asdf.

I’m getting this error:

iex(1)> :observer.start()

20:29:12.363 [error] ERROR: Could not find 'wxe_driver.so' in: /Users/cristhianfuertes/.asdf/installs/erlang/22.2.1/lib/wx-1.9/priv

{:error,
 {{:load_driver, 'No driver found'},
  [
    {:wxe_server, :start, 1, [file: 'wxe_server.erl', line: 65]},
    {:wx, :new, 1, [file: 'wx.erl', line: 115]},
    {:observer_wx, :init, 1, [file: 'observer_wx.erl', line: 107]},
    {:wx_object, :init_it, 6, [file: 'wx_object.erl', line: 372]},
    {:proc_lib, :init_p_do_apply, 3, [file: 'proc_lib.erl', line: 249]}
  ]}}

So I checked the readme for asdf-erlang and followed this advice:

For building with wxWidgets (start observer or debugger!) brew install wxmac

But I’m still getting the same error after installing that package.

Try re-installing Erlang now that you installed wxWidgets package.

~$ asdf install erlang 22.2.6
2 Likes

That did the trick. Thanks

1 Like