Erlang docs with asdf-vm

I’m using asdf-vm, and trying to get documentation lookup for erlang modules to work.

I compiled erlang with docs, and I can run (eg) ‘erl -man timer’ to get a man page. But in iex, if I run ‘h :timer’, I get ‘:timer was not compiled with docs’.

I’m wondering if this is just not supported yet because of doc formats, or if I have some version mismatch with the asdf precompiled elixir binary.

Here’s the versions I’m using:

$ elixir --version
Erlang/OTP 21 [erts-10.1] [source] [64-bit] [smp:4:4] [ds:4:4:10] [async-threads:1] [hipe]

Elixir 1.8.1 (compiled with Erlang/OTP 21)

$ cat ~/.tool-versions
erlang 21.1
elixir 1.8.1-otp-21

Ultimately, what I want is to be able to look up erlang functions’ docs in emacs with ‘,-h-h’ via the lsp.

1 Like

In this topic:

There is a link to Erlang's bug tracker:
https://bugs.erlang.org/browse/ERL-708

In which there is a comment:

Kenneth Lundin added a comment - 22/Nov/18 2:57 PM

Hi,

I will try to make some progress regarding this in OTP soon and at least take a decision about what to do about this for the OTP 22 release.

Finally there is 22.0-rc1 version of Erlang in asdf-erlang plugin, but I did not tried it yet. As you can see issue have still open status and it’s also not yet resolved, so it’s most probably not yet added to it.

For more information you would need to ask somebody from Erlang Core Team as I did not yet found anything other. Maybe somebody is already working on this … Author of previously mentioned comment is assigned to this ticket, so there is a chance to see stable support for it really soon.

4 Likes

I was trying this last night and had the same issue. With asdf in the erlang readme it lists out all of the package dependencies that need to be installed on Ubuntu but even when I installed them I was getting not found messages about the docs and wx.

So, it sounds like the docs just won’t work until the transition to a new format is done. But you’ll still want to get erlang compiled with wx so you can use the observer.

I’m just wondering if there is a special setting needed. The installation tells me it’s missing packages that are definitely installed.

I’m going to try installing via the PPA instead and see if it makes a difference.

Which packages are this? Please be aware that the installer might tell you to install libwx but you actually need libwx-devel or something. Most Linux distributions do this separation of libraries and their header files.

3 Likes

Following the instructions here:

I’m not in front of it right now, but from memory it would be missing wx, fop, xsltproc, and odbc

1 Like

Seems to be working now. You have to search for some different names of packages but eventually it all gets working. https://packages.ubuntu.com/search