Help sending mail through SendGrid / Bamboo


I have the following coniguration in my releases.exs

  config :botclient, MyAPP.Mailer,
   adapter: Bamboo.SendGridAdapter,
   api_key: System.get_env("sendgrid_key"),
   hackney_opts: [
     recv_timeout: :timer.minutes(1),
     connect_timeout: :timer.minutes(1),
     ssl_options: [
       versions: [:"tlsv1.2"]

Whenever I try to send an email, I’m always getting the following message with or without the hackney_opts

** (Bamboo.ApiError) {:options, {:sslv3, {:versions, [:"tlsv1.2", :"tlsv1.1", :tlsv1, :sslv3]}}}

I have tried to read through the documentation to check whether I’m missing something but there’s nothing more in terms of configuring Bamboo to use SSL. I will appreciate any form of assistance

My sendgrid config is a little bit different…

config :emailer, Emailer.Mailer,
  adapter: Bamboo.SendGridAdapter,
  api_key: "my key...",
  # can be `:always` or `:never`
  tls: :if_available,
  # or {:system, "ALLOWED_TLS_VERSIONS"} w/ comma seprated values (e.g. "tlsv1.1,tlsv1.2")
  allowed_tls_versions: [:tlsv1, :"tlsv1.1", :"tlsv1.2"],
  # can be `true`
  ssl: true,
  retries: 1,
  # can be `true`
  no_mx_lookups: false,
  # can be `:always`. If your smtp relay requires authentication set it to `:always`.
  auth: :if_available

interesting, let me try this and let you know how it goes

Same result. Where’s this documentation so that I can go over it and look at other configuration options?

you might need to update hackney in your deps, I had the same error when I updated elixir bumped in to this and after updating hackney all is good now