'mix ecto.create' errors with: role "postgres" does not exist

phoenix
postgres
mac
#1

Just posting this here in case it helps anyone else in future.

on mix ecto.create I was getting:

00:54:48.033 [error] GenServer #PID<0.214.0> terminating
** (Postgrex.Error) FATAL 28000 (invalid_authorization_specification) role "postgres" does not exist
    (db_connection) lib/db_connection/connection.ex:84: DBConnection.Connection.connect/2
    (connection) lib/connection.ex:622: Connection.enter_connect/5
    (stdlib) proc_lib.erl:249: :proc_lib.init_p_do_apply/3
Last message: nil
State: Postgrex.Protocol
** (Mix) The database for Hello.Repo couldn't be created: killed

and psql was reporting:

psql: FATAL:  database "Aston" does not exist

See answer below…

2 Likes

#2

Fixed with:

createdb 'Aston' 
psql

(Change Aston to whatever the psql command in the post above said was missing)

Then:

CREATE USER postgres SUPERUSER;
CREATE DATABASE postgres WITH OWNER postgres;
exit

(Although it told me the postgres db already exists - something you can check with psql -l)

mix ecto.create
$ The database for Hello.Repo has been created

:smiley:

2 Likes

#3

That’s kind of weird. PostgreSQL should always come with a created postgres user. I’d wager on a broken installation.

2 Likes

#4

Yeah something weird is going on. I haven’t done a clean install for a while, just update after (MacOS) update - I generally hate settling with updates as things always break and start to feel sluggish after a while. But Apple being Apple have made clean installs harder - last time a clean install totally broke my email settings and I had to report it as a bug to get an answer on fixing it! :icon_eek: I’ll only do a clean install now if I have a week or two spare :lol:

Reason I posted the thread here is because when searching I noticed someone had commented they got the same error after running mix ecto.create too! So thought having it more easily and directly google-able might help others in future :smiley:

1 Like

#5

Agreed, but the Homebrew installation creates a SQL user named after your OS user and no “postgres” user to go with it. Just something to document and be aware of like @AstonJ has done here :+1:

2 Likes

#6

Ah that explains why when using Rails it works fine - because I guess they use your account name user rather than ‘postgres’.

I wonder if Ecto could detect whether you’re using OSX and do the same? Otherwise every Mac user who have installed PG via homebrew will get the same.

Alternatively maybe hombrew could create the postgres role on installation too?

0 Likes

#7

So for me the disconnect is that the generators hard-code the literal value of “postgres” for username on the Ecto connection, but really what it needs is a SQL user that is a superuser or that has DB creation rights. I would prefer some explicitness/agnosticism in that direction be included in the Phoenix generator output, and/or in the Hex docs, instead of assuming I’ve left the default “postgres” user intact and with superuser privileges.

I don’t do that on my dev workstation or my production DB either, so I wind up using a Repo.init/2 callback and a DATABASE_URL basically immediately on new projects.

1 Like

#8

Not sure. I installed PG through homebrew as well and I seem to remember it having the postgres user and a fresh Phoenix app working right away. But then again, that was a while ago, can’t swear the details on my life.

As for the Ecto default, you’re not wrong but then again they apply for local-only config so I see no harm done.

0 Likes

#9

But if you’re working on a shared project, you’re probably better off with everyone using the postgres user locally, or not setting one at all (which I think will default to the logged in user)

0 Likes

#10

Hi guys! I got the same error:

16:05:28.295 [error] GenServer #PID<0.220.0> terminating
** (Postgrex.Error) FATAL 28000 (invalid_authorization_specification) no PostgreSQL user name specified in startup packet
    (db_connection) lib/db_connection/connection.ex:84: DBConnection.Connection.connect/2
    (connection) lib/connection.ex:622: Connection.enter_connect/5
    (stdlib) proc_lib.erl:249: :proc_lib.init_p_do_apply/3
Last message: nil
State: Postgrex.Protocol
** (Mix) The database for Getaways.Repo couldn't be created: killed

and fixed it. It was due to the config on the dev.exs file (at the end of it):

Originally:

# Configure your database
config :getaways, Getaways.Repo,
  username: "postgres",
  password: "postgres",
  database: "getaways_dev",
  hostname: "localhost",
  pool_size: 10

Fixed:

# Configure your database
config :getaways, Getaways.Repo,
  username: "yourcomputeruser",
  password: "yourcomputeruser",
  database: "getaways_dev",
  hostname: "localhost",
  pool_size: 10

The setup by default is “postgres” => updated them to my computer user.

I hope it helps!

1 Like

#11

I’m thinking you need to have a look at your pg_hba.conf and make sure you are actually permitted to log into Postgres.

Have you tried getting in simply with psql -U postgres?

1 Like