Unpacked: Multi-Player Bingo (Pragmatic Studio)

pragmatic-studio
Tags: #<Tag:0x00007f8e9d2415e8>

#1

Get 20% off with coupon code “elixirforum”!

https://pragmaticstudio.com/unpacked-bingo


Full stack Ember.js & Phoenix (self-published)
Elixir Forum Update - 2018!
#2

I’m excited about this course and would love to hear a review of it if anyone has taken it. Also, what level is it for? Total beginner, novice, advanced?


#3

Looks like a great course! I’m also finding it interesting how so many of the Elixir learning resources are using games as their example apps - different to what I’m used to in Ruby where you often find they use online shops, twitter clones, blogs etc :slight_smile:

I’m guessing you have to do this after their Elixir and Elm courses - if you watch the intro video they say:

…this is different, because you’re beyond the beginner level. We’ll start with the completed app and unpack it layer by layer, focusing less on the syntax and and more on the design.

Agree with you about reviews - if anyone does this please let us know what you think :023:


#4

That is true, and I did watch the video and hear that. But I’ve seen that a lot of courses say they are not for beginners, and end up still hiding or not going over any of the complexity. Either way, definitely interested in hearing reviews.


#5

Working through the course, so far only the elixir content is available in video - although the whole codebase for the bingo app is available to browse.

The quality is great, code is presented very cleanly in VS code, with IEx sessions.

They assume a working knowledge of Elixir and Elm - deliberately skimming over the sequential game logic modules as that is not the focus of the course.

The coverage of DynamicSupervisor, Registry and GenServer to represent game sessions is great.

Looking forward to the Phoenix channels/presence and Elm content.


#6

I bought it for only $25.6 (early access + elixirforum coupon code), not bad.


#7

Just to confirm, that yes, you can use your forum coupon to get 20% off this or any other Pragmatic Studio course :023:


#8

Did anyone actually try to get the game to work? It launches with one user, but I cannot get another user on the same or different computer to join.


#9

Actually, it doesn’t launch fine with one user either. Clicking any word results in an “UNMATCHED TOPIC” flash until you refresh the browser.


#10

I don’t get why Mike does the videos with Nicole if does the talk 90% of the time?

So my expectation would be more around 50% / 50% between both.

NOTE: This observation comes from watching only the introductory videos.


#11

If you are testing this on separate computers you need to launch the server like so: “env WS_URL=ws://192.168.1.143:4000/socket/websocket mix phx.server” where you substitute your IP address. Otherwise it defaults to localhost. Thanks to Mike and Nicole for helping to debug this.


#12

Also, this line in Bingo.elm causes the player scores to disappear after awhile:

Phoenix.Socket.withoutHeartbeat

It’s there to declutter debugging. Removing it results in a stable client experience.
Thanks again to Mike and Nicole for their support.


#13

Vue.js is also included now, in case you don’t wanna use ELM at the front-end. Sale ends tomorrow.


#14

Hijacking this thread since it IS related to this course and I can’t seem to find a help forum/board/etc. from PragStudio.

So, long story short, in the setup notes (1st “lesson”), for the Elm section it says to go to assets folder (under the elm folder) and run elm-package install -y.
I tried that, indeed there IS a file there elm-package.json but my OS doesn’t recognize elm-package as a command (it’s the first argument of the “sentence”).

Also tried, npm install elm-package and no joy.

So, before I continue forward to more advanced lessons, how do I tackle this issue at the gate?

Also, are the docs/explanation of later lessons correct (from your experience)?

Thanks in advance and sorry for the hijack (though, one may say that knowing about issues in this course are just as important as knowing about its strengths. :smiley: ).


#15

On macOS:

$ ls /usr/local/bin/elm-package
/usr/local/bin/elm-package

So what likely is happening is that your $PATH (System PATH) environment variable doesn’t contain the path to the directory that Elm was installed to.


#16

That sound very plausible since I had to install Node.js (and by that virtue, Elm) to a custom folder (long story…)

So elm-package IS a command, just not OS, but one installed by installing Elm… Cool, I’ll just EXPORT it to the path (once I find it. :slight_smile: ).

Thanks again!


#17

What installer did you use? I don’t remember there being an npm installer before - and that would work slightly differently and it would depend on whether you used

npm install -g elm

or

npm install elm

npm list -g --depth=0

would list all globally installed npm packages - and if that doesn’t work you may have to get npm/node to work properly first.


#18

I used NPM, however for some reason I’m not sure of, even using sudo and the -g flag all resulted in permissions error to write to a certain folder NPM uses.

I found some GH solution where you set the global installs of NPM to a folder of your choosing, which worked. The downside is that, indeed, as you suspected, using this method doesn’t put the custom folder on the PATH.

A quick editing of the .zshrc and I’m off to the races. :smiley:
Thanks!