SpaceVim - like SpaceMacs but for Vim!

SpaceVim is a community-driven vim distribution that seeks to provide layer feature, especially for neovim. It offers a variety of layers to choose from. to create a suitable vim development environment, you just need to select the required layers.

http://spacevim.org/

Anybody tried it?

5 Likes

Looks neat… installing it now :slight_smile:

I’ve tried it in two places on two computers and it just loads to a blank vim-screen in both, and one of them was an entirely fresh neovim install as well.

I installed only for neovim and … it workded :blush:
But some plugins failed…

^^/Downloads >>> curl -sLf https://spacevim.org/install.sh | bash -s – --install neovim 22:56:51
==> Trying to clone SpaceVim
Cloning into ‘/home/michal/.SpaceVim’…
remote: Counting objects: 8997, done.
remote: Compressing objects: 100% (35/35), done.
remote: Total 8997 (delta 27), reused 36 (delta 18), pack-reused 8944
Receiving objects: 100% (8997/8997), 1.88 MiB | 1.61 MiB/s, done.
Resolving deltas: 100% (6301/6301), done.
Checking connectivity… done.
[:heavy_check_mark:] Successfully clone SpaceVim
[:heavy_check_mark:] BackUp /home/michal/.config/nvim to /home/michal/.config/nvim_back
[:heavy_check_mark:] Installed SpaceVim for neovim
^^/Downloads >>> nvim 22:57:37
:!git clone https://github.com/Shougo/dein.vim “/home/michal/.cache/vimfiles/repos/github.com/Shougo/dein.vim”

ok
After restart all plugins were updated.

If only it would work here for me. :frowning:

I wonder if neovim has a log file somewhere…

EDIT1: Oh hey, it works when I don’t have a GUI (terminal mode), it only fails to load if I load the GUI version of neovim, wtf…

EDIT2: Ah hah, the GUI version is dying because it is lacking a font, wtf again…

Finally got it to load all packages after having to quit and restart Vim a few times.

Which additional packages have you all added?

Quick initial thoughts… I like it! :023: Wonder if we could have something similar for MacVim?

@OvermindDL1 - Which OS are you on? Good luck! :lol:

Currently Windows 10, since I am at work. It seems to work in terminal mode fine. :slight_smile:

Only things that failed to build where the phpcd and phpfold plugins, which I don’t care about. :slight_smile:

1 Like

Initial Impressions compared to Spacemacs is that it is a lot faster. Spacemacs can take a second to refresh with commands sometimes, but that may be because not a lot of plugins are installed yet.

2 Likes

Tried it just now, it is indeed a lot faster. Got several “Key not present in Dictionary” errors on installation but when it ends it all seem to start fine. Works great on both terminal and GUI.

But the commands seem incomplete and/or too different from Spacemacs, notably the projects menu (SPC-p-*), and I’m also unable to understand how the file tree (vimfiler?) on the right is supposed to work (it only stays in my home directory). Atom’s proton-mode behaves better…

SpaceVim use true colors by default, you need to make sure your terminal support true colors, otherwise, you can add let g:spacevim_enable_guicolors = 0 to your custom configration file.

the latest version of SpaceVim will show the error message when plugin building failed.

ohh, you can have a look at my SpaceVim config, I have 270+ plugins installed, but it is still very fast.

This is in the GUI. :wink:

I’ll need to, I may have to play with this a lot more. :slight_smile:

@SpaceVim - Hi Wang, uninstall isn’t working for me

curl -sLf https://spacevim.org/install.sh | bash -s – uninstall

Any idea what’s going on or what the manual steps are please?

[~]$ curl -sLf https://spacevim.org/install.sh | bash -s -- uninstall
==> Trying to update SpaceVim
Already up-to-date.
[✔] Successfully update SpaceVim
[✔] Installed SpaceVim for vim
ln: /Users/Aston/.config/nvim: No such file or directory
[✔] Installed SpaceVim for neovim

Installing SpaceVim takes over your MacVim too :lol:

I skimmed the install script:

 case $1 in
        --uninstall|-u)
            info "Trying to uninstall SpaceVim"
            uninstall_vim
            uninstall_neovim
            exit 0
            ;;

So it has to be:

curl -sLf "https://spacevim.org/install.sh" | bash -s -- --uninstall

But you are right, by intuition I had tried it as a subcommand as well, not as a flag…

1 Like

Thanks @NobbZ :023: (I had just copied the command from an issue on GitHub)

That’s done it, and my MacVim is back to normal :003:

I’ll probably revisit it again at some point tho :slight_smile:

I think the uninstall script is broken, I will look into it.

I’m trying to change the default theme but it’s not working - any idea what’s going on?

This is what I’d normally do:

color Elixify
set guifont=Menlo:h12
set linespace=2

I’ve tried the following in .SpaceVim.d/init.vim

let g:spacevim_colorscheme = ‘Elixify’
let g:spacevim_guifont = ‘Menlo/ 12’

But it doesn’t work.

Also, how can I copy text to the clipboard to use in an external app? In normal MacVim we can just do Command C (or even yank as normal) then paste as normal into an external app.

Hi!

SpaceVim can not find the colors, you need to add custom colors chrome via spacevim_custom_plugins, BTW, what is the value of &guifont in your normal macvim, just change spacevim_guifont to it. For copy something you can use y or add your custom mappings.

If you still can not get it work. please open issue in SpaceVimZ’s github repo.

thanks!

I want to improve the elixir layer, any recommand vim plugin for elixir?